Metadata Genre Issue

I use local metadata for movies. With the recent update, genres for the local metadata haven’t been read properly. For movies that I ripped from BluRays I’ll give them the genre “BluRay.” DVD’s, the same. I then add these genres to my favorites and it lets me sort things the way I want without having move files around my drives.

Once I updated the most recent update on AppleTV these genres stopped being present in the genre list. What I have to do to get them to work is go to each film and select local metadata. There are far too many to do this manually. Also, after closing the app, most of them reset and the bluray/DVD genre disappears.

The same thing happened in the iOS version, but simply refreshing the metadata in each folder solved the issue. Nothing has solved the issue on AppleTV, including removing the source, reinstalling the app, etc.

Edit: I just want to add, I have a second AppleTV with autoupdate turned off on the App Store. The Infuse version that the second ATV has is 6.2.2. Infuse doesn’t have that issue on that version.

Are you using embedded metadata, or external XML files to add these genres?

If using external files, would you be able to upload a sample?

Hi, James. I’m gonna go ahead and submit a diagnostic report, because my issues have become many after reinstalling the app. It’s too many things for the forum. Thanks though.