Metadata for tv-shows

I can’t get custom metadata for tv-shows to work at all. All episodes only appear in the “Other” section.
The files are managed according to the following sequence:
\Server-name\Shared\Series\SeriesName\Season [1-n]\SeriesName - S[1-n]-E[1-n] - EpisodeName.mkv

e.g \Server-name\Shared\Series\Big Bang Theory\Season 4\Big Bang Theory - S01-E01 - The Robotic Manipulation.mkv

and each file has a corresponding xml-file to it but it does not work. (see uploaded picture for xml file)

I have plenty of own series so getting this to work is extreamly important for me.
May someone help me to get me to understand what is needed to get it work?? Please!

** This one is solved.
** The (bad) solution was make sure all series was SeriesName\Season [1-n]\SeriesName -[1-n]E[1-n] - EpisodeName.[Extension]
** and then have Metadatafetching On.
** The series than could not be connected to a show ended up in Other and there I had to connect it to a random series name.
** This means a lot of series has wrong name showing but correct artwork
** Since I dont want to have Metadatafetching On for movies I first had to dissconnect the movies, add the series, turn fetching off again and add the movies.


In your example filename you have 'S01-E01’ … Is that a typo as it doesn’t match what is expected and your earlier specification. I would expect it to be ‘S01E01’.

that was a typo. The xml file and the mkv (or m4v)-file has the same name, except for the extension. (the original text is updated)

Have you tried changing one to S01E01 (without the hyphen). That is how I have mine named and they seem to work fine. If that works maybe it is worth adding a post in the suggestions forum to see if they can add support for a hyphen in the way you are using it.

Try “The.Big.Bang.Theory.s01e01”

Currently, in order for TV shows to appear in the Library, you will need to have Metadata Fetching enabled and the shows will need to match against something on TheTVDb. It won’t really matter what they’re matching since you’re overriding the fetched info with your own XML/artwork anyways.

We may look at adding more flexibility in this area for a future update, but with how the Library works allowing manual additions for TV series is a rather complex addition.

Thank you for your reply James. I have tried your solution but it did not work. When Metadata fetching is enabled almost all series is fetched as single movies! It works for the big brands like Big Bang Theory, CSI, NCIS but for the rest it gets really ugly. (And as you know, when fetched as a movie, you can only change metadata to other movie titles). And to get the real movie-library to work I must have Metadata fetching off as you have explained in other threads to other people.

So I really, really need the feature to have the system scrap from my xml-files while having metadata fetching off!

1 Like

Can you provide an example of how these videos are named? You may check to ensure you’re using of the support TV show naming styles described here. Metadata 101 – Firecore


Disney Hjärtevänner - 01 - Society Dog Show.m4v

Kenny Starfighter - S1E1 - Vårt Sista Hopp.m4v

SUNES JUL - Avsnitt 1.m4v

The Saint - S01 - E01 - The Talented Husband.m4v

Complete Goofy - 01 - 1939 - Goofy And Wilbur.m4v

I want to say thank you James for helping me out in this case.
I have started to rename some of my series-files so when they get stranded in ‘Other’ they can be matched to a random seriesname.
A small problem here is the name of the series does not get changed! It still contains the same Series-name as I randomly choosed.

One thing I found out is if you want custom pictures to display as cover the first files must be in a folder named “Season 1”. Example:

/Big Bang Theroy/Season 1/Big Bang Theory - S01E01 - Pilot.mkv
/Big Bang Theory/Volume 2/Big Bang Theory - S02E01 - XXX.mkv
/Big Bang Theory/Season 1-poster.jpg
/Big Bang Theory/Season 2-poster.jpg

The example above will match the videofiles into to separate Seasons for big bang theory and give them the covers från the jpg-files. If however the Season 1 video file is not in a Season 1 folder it will not give the jpg-files as cover.

(In most cases you will want to have series in season-foldes but I have a few videofiles in “bonus” folders and to get correct cover the first season must be in a “Season 1” folder.)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.