Metadata for The Frankenstein Chronicles tv series

I have one TV series, The Frankenstein Chronicles, which is listed on but which Infuse just refuses to match.

My files are of the form:

The Frankenstein Chronicles/Season 1/The Frankenstein Chronicles S01E01.mkv

Even selecting the Edit Metatadata option and entering ‘The Frankenstein Chronicles’ does not bring up any choices. I have managed to match all my other TV series except this one which has me stumped as it is definitely listed on

Try “The Frankenstein Chronicles (2015)”. Worked for me in some cases.

Thanks for the suggestion … but unfortunately makes no difference, still cannot be found.

I have several TV series which require the year like you suggested, but they all have an entry on with the year in the title … this series does not have a year in the title on But I tried it anyway just to be double sure.

I’m having the same issue with the same series. Strange that it’s just that one (for now) that is on site but doesn’t show when searched for.

Hey James, any ideas?

Well, I figured it out, or at least for me. When you search, use “Frankenstein Chronicles” without the “The” in front. For me it brought up “The Frankenstein Chronicles 2015” and loaded the correct metadata when selected.

Seems that somewhere the word “The” got lost in the search. Not sure if it’s an infuse issue or a tmdb issue but anyway it worked.

Hope this helps you out too.

Leaving off the ‘The’ sorted it … Just entering ‘Frankenstein’ in the edit metadata search bought up the correct entry ‘The Frankenstein Chronicles’.

Thanks for finding the solution and letting me know.