Metadata cache keeps clearing!

This would work very well as an optional (advanced?) user setting for an additional backup location. And Infuse seems to already have all the necessary pieces: it could use the same flow and UI components as when adding a share, perhaps with only a subset of supported protocols; no need to handle a database on the share either, just copy backup exports back and forth; fallback to iCloud if the backup share is unavailable.

It’s still mostly getting blown off…

I simply do not understand what is going on here. Firecore are still refusing to develop a true solution to this, and making claims which are simply untrue.

It is untrue that nobody would have the ability to setup write access to their NAS, if they own a NAS, then they know, by definition, how to setup access rights, which are usually defaulted to RW access anyway, and as far as the capabilities of that share are concerned, Infuse has a bult-in speed test, does it not, and can query free space before committing to the process? If Infuse performs a speed test and gets a number lower than X, then it needs to inform the user, and switch to iCloud only mode. Also, use the temporary cache in the ATV to compile the DB, then load it in hash-checked chunks of 128MB so that there is no random access of thousands of small files going on the NAS. If a NAS can stream a 4K Dolby Vision RIP to Infuse, then it can handle a 4GB database served in 128MB error checked chunks.

Also, Firecore is going to have to inform customers about how much iCloud space Infuse would take up anyway, as many would have to upgrade from the free storage tier Apple provides to cope with the extra storage demand.

The setting to use the NAS as the database storage backup location would have to be optional, and most customers would be fine that not all internet-based storage services would be supported from day one, if ever supported due to speed, latency etc. As long as there is communication, which is not Firecore’s best strength. You will just have to try harder; your customers are not as dumb as you may think!

1 Like

Would everyone in this thread agree that this is such an app-breaking bug that Infuse developers shouldn’t work on other bugs or features until this is completely resolved?


I mean, this bug literally renders the app useless on ATV which is the only way i use it, yeah they should literally put all brainpower to solve this. i mean how hard can it be to store some textfile with the filereferences and let the rest (movieposter images) get downloaded and displayed when you use the app. apps like youtube download the thumbnails also on the go.

1 Like

Yes. Infuse is unusable on an ATV right now (my second ATV just started doing this a week ago). Maybe if Apple release a new ATV with double the storage space every year, we can stay ahead of this Infuse design flaw!

But I’m sure there are many that are going to say that we are using it or Infuse wrong, and it works perfectly fine for them, and they never have issues.

One day they will, and FireCore will still be here, finding it too hard to bother about. My hope is that it’s an Apple thing, (yes, I know that Infuse is in breach of Apple’s developer guidelines) and gets fixed in a new tvOS, as it seems this problem is wildly exasperated by tvOS constantly downloading screensavers.

It’s clearly a tvos bug.

I don’t see how, with all the good will they have, these guys can fix an os bug.

I read. Write about it in the tvos support forums. Hopefully the Apple engineers will catch it and fix it.

1 Like

For my use case I will have to say no. I mentioned this a few posts back, but Infuse has two main components: library manager and player. These are pretty big shoes to fill, and arguably bigger players in this field have a hard time getting it right (Plex?). But since I choose to manage my library freely, as in free of cost, subscriptions or memberships, I have other solutions for that. The only thing that gives Infuse an edge on ATV is the player part, which it does better than everything else I tried, but still not good enough: see a number of bugs that are being worked on right now.


Please explain.

I thought you were going to stop posting ITT.

I have family members who have been using Infuse for years and have just given up on the app. Have tried the workarounds on their ATVs and nothing. It’s really sad.

I think I will probably stop paying for Pro at the next cycle if this doesn’t get fixed, and try the other apps out there.


I’ve discovered this thread today after experiencing this on both my ATVs constantly for the past month or so.

There’s lots of discussion here and I might of missed it due to the volume of posts. Can someone explain why the Plex app for ATV isn’t affected by this metadata issue, but Infuse is?

1 Like

Plex stores its cache on its own server while infuse stores its cache on the Apple TV. infuse could be rewritten to pull data on demand from the plex cache and not use the library and then it wouldn’t be affected, but it can’t work that way for regular file shares.

Thanks for the context. Having an option to use Plex server cache instead of how Infuse currently handles metadata would be ideal, so I don’t have to see this message ever again :upside_down_face:

This metadata issue and the lack of alphanumeric scrolling is really killing my viewing experience in Infuse. I hope they can fix these things sooner than later.

Sorry to disappoint you.

This post, and the one following it, cover most everything, but for Firecore’s subsequent responses — scan for the posts by @james for those.

I know how to solve this.

Make Infuse a bigger install (at least optionally).

Fill the app with your own demo videos - that Infuse can choose to delete from itself to free up space as its metadata gets larger.

Initial install: 10gb. (1gb app / 9gb demo videos)
User meta data increases: (1gb app / 1gb metadata / 8gb demo videos).

Apple (assumably) doesnt charge you more for hosting a larger app right?

Come on bud get clever here.

Or Infuse could simply rely on the meta data and images stored in the actual content folders on our file servers.

We all have file servers.

No reason that Infuse could simply be toggled to just pull from the metadata that most of us already have stored on our servers.

Or just let me create a share on my file server for Infuse’s metadata - problem solved.

1 Like

The storage you are talking about is the app bundle itself and is read-only.

You are incorrect. This maybe an OS bug, but it is affecting Infuse because FireCore have designed Infuse to use a cache on the ATV which is not allowed for long-term storage. They designed this app in breach of Apples developers guidelines for tvOS.

You’re not going to get far blaming Apple for FireCores bad app design.

No, you really don’t. :roll_eyes:

Correct. And in addition, it’s limited to 4GB (as I previously made clear).

In order for this thread to continue the bickering and sniping needs to cease.

If you have something constructive to say about the topic then keep the scope of your reply to that only.

Leave the personal goading and condescending remarks out of it.


"Or Infuse could simply rely on the meta data and images stored in the actual content folders on our file servers.

We all have file servers.

No reason that Infuse could simply be toggled to just pull from the metadata that most of us already have stored on our servers.

Or just let me create a share on my file server for Infuse’s metadata - problem solved."

I have been saying this since before the asteroid strike that wiped out the dinosaurs…
The technical double talk i was given in objection to this was RIDICULOUS

1 Like