Metadata - Another "big" issue

mmm I don’t know if it’s me :slight_smile: but I have another issue with the metadata association.

at this time Infuse “invent” the file names :slight_smile:

On my NAS I have a folder “Alien” with the alien’s film.
One of them has it’s named: Alien III.mkv

Now, when I opened Infuse… Infuse showed me the artwork of “Alien Nation: Dark Horizon”.
at first, I didn’t understand why… then I enabled the “show file names” and I saw that Infuse detect my “Alien III.mkv” as “Alien Nation: Dark Horizon.mkv”. LOL

I had the same issue with a lot of other files… where Infuse change the file name with an unexistent one :frowning:

Obviously, if I navigate my NAS with VLC or with other client, the name of the files are correct.

this is a big issue.

see the first attachment (I manually changed the metadata artwork from Alien Nation: Dark Horizon to the right one).

see the second attachment for another example:
According to Infuse there are 3 files with the same name (Don.avi) on that folder.

  • first: it’s not possible, and it’s not as Infuse detected.
  • second: there’s no files named Don.avi, instead there are these files:
    ---- Don Camillo 1952.avi
    ---- Don Camillo e l’onorevole Peppone 1955.avi
    ---- Don Camillo Monsignore ma non troppo 1961.avi

Its seems that Infuse as some issue when there are more files with the same prefix…

From Infuse options, I’m using NAS UPnP sharing mode.

LG OLED 55E6V - DENON AVR-X4100W - Front KLIPSCH RF 82 MKII - Center KLIPSCH RC 62 MKII - Surround KLIPSCH RS 52 MKI - Subwoofer SVS SB13 ULTRA - NAS QNAP TS-453A 16GB Mem 16TB->4x4TB Raid 5 - SKY Q + SKY Q Mini - XBOX ONE X - Apple TV 4K 64Gb

20180114_143306.jpg

20180114_144925.jpg

Try and rename the files as per attached screen capture.
Alien 3 should be “Alien.3.1992.mkv”

When you use UPnP the file names provided to infuse can get scrambled or changed. You’ll get better results using SMB, FTP, or one of the other choices instead of UPnP.

The same server has Plex server installed. I don’t want to rename all my library (over 10 TB).
and mostly, I have to look manually each file one by one in order to see if the artwork is the right one, or if Infuse got the wrong name?? it’s a joke :slight_smile:

I use the same server with other clients, and I don’t have this issue. It can’t be the UPnP vs SMB. We are talking about a file named “Alien III.mkv” vs “Alien Nation: Dark Horizon-mkv”
this is not a scrambled name, or changed (I don’t have that file in my library… is it the spirit who “invent” that filename?? :wink: )

there’s a bug somewhere. Also, 3 file with the same “prefix” has been “invented” with doo.avi. :slight_smile:

I’ll give a try to SMB…

Here’s another thread that may help explain.

sorry, but it’s not an explanation :slight_smile:

UPnP and DLNA servers will index (and often times rename) files, so what Infuse sees won’t always match what you have on your NAS.

are there any documentation about this renaming issue? and, in your opinion: why “alien III.mvk” should be renamed with “Alien Nation: Dark Horizon.mkv” ??
I don’t have any file named “Alien Nation: Dark Horizon.mkv”. how is it possible that a “spirit” will rename (and WHY it should be) a file, with a new name which really exists but not in my library ? :slight_smile:

again, it’s a joke. I’m not talking about “Alien III.mkv” renamed as “alineIII.mkv” or something similar… but in a name totally different and without any clue about it.

IMHO Infuse tried to match “Alien III.mkv” and since it doesn’t find any match, it try to match to another one, internally renaimg it into “Alien Nation: Dark Horizon.mkv”.

but this situation is not acceptable, Infuse should do exact match, and left over tthe unmatched one, so that I may see a black icon and understand that the file hasn’t matched, and I may manually find a match.

I have many other kind of client which reads NAS files as UPnP and only Infuse has this issue.

What other clients are you using that have no issues with file naming?

LG OLED internal DNLA player, another TV Samsung with its internal DNLA player, Kodi from my laptop.

Question:
if you copy any your mkv and rename it as “Alien III.mkv”, with which name is it recognized by Infuse?

my doubt concern that I haven’t any file named “Alien Nation: Dark Horizon.mkv”, so this name where does it came from??

I also tryed to restart Qnap, and reindexing all the library. I got the same issue.

mmmm something strange happened. Now even on my LG I had the same issue. So there’s something related to my QNAP… but for sure I haven’t had this issue before, and I’m using my LG/QNAP for a year without any issue (and I saw all the alien’s film also).

I’m going to investigate on what happened…

If you use Alien 3.mkv it works fine. If you look at themoviedb listing you’ll see it’s listed as the number 3 and not roman numeral III.

I’m guessing that Infuse is seeing the three “I”'s as letters and trying to get the closest match.

Sorry, was just trying to help with references to other threads where UPnP was the culpret and changing to SMB solved the problems. You will solve the Alien issue by using the numerical 3 if that helps at all.

Did you try SMB?

The issue isn’t related to Infuse, since now I had the same issue with my LG TV. So the issue is with my QNAP server.
In the last 2 days I did a massive file uploads, and now I think that something went wrong on my QNAP during the last reindex.
But again, I haven’t any file named “Alien Nation: Dark Horizon.mkv” and even with indexing errors I don’t understand where it came from.

Now I turned off the DNLA server, and I’m running a full reindex from scratch.


With SMB it works without any issue (it works with directly with files). But now I have to resolve DNLA issue, or I can’t use my TVs properly anymore with the internal DNLA players.

Alien III.mkv has been correctly matched to Alien3 with the correct artworks (but I was sure about this, since even Plex Server matched it correctly)

Ok, after a full reindex of the files on my QNAP DNLA server, all it works again as it should be, and even Infuse reads “Alien III.mkv” properly (and the other “Doc…” issue are gone).

UPnP/DNLA works as expected, in case of wrong file names, just reindex the DNLA server. Probably my last massive-uploads scratches the DNLA indexes.

btw, it’s a mistery for me about where “Alien Nation: Dark Horizon.mkv” came from…

@NC Bullseye thanks for the help :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.