Meta ok but no cover

Hi guys

I can’t understand why some of my movies on my NAS are not being matched with right Movie Cover… Infuse keep giving them a random picture of the movie even if all the meta of the movie is correctly added… any help ? thx a lot
no need to add that nothing (no picture) is in the folder of the movie on the NAS

thx a lot !

Do you by chance have “Embedded Metadata” turned on in Settings?

Hi NC Bullseye, yes it is. Should I disable it ? on each device with Infuse right ?
I have to mention that a plex server is running behind on my NAS.
Thx a lot !

I don’t run plex so I can’t address if there would be other issues but I don’t think it’d hurt to toggle it and see if that allows the files you’re having issues with to fetch the correct metadata artwork.

Worked perfectly ! thx a lot ! :v:?

Super! Glad you’re back on track. Enjoy :slight_smile:

I’m having the same issue with just one tv show: Wayward Pines.

I already tried to force metadata and I also have “local metadata” disabled.

For this issue it’s really a totally different problem, the OP had movies that were showing a pic from the video. For you’re it’s a TV series that’s not showing the Series poster and is showing a blank icon.

Also the OP is using an Apple TV and it appears you’re on an iPhone?

Does it show the correct season poster? Does it show the correct metadata for each episode?

How are your files named and how is the Series folder named on your server?