Mediaplayer no audio any all videos

I updated to the newest version of mediaplayer and all of all my videos no longer play audio. Tried rebooting the atv2 and nothing. I can get audio working outside of mediaplayer so it has to be a problem with mediaplayer. Any suggestions on a fix?

What type of files is this occuring with?

Do you have the AC3/DTS options enabled in the Media --> Settings menu?

Hey, Yes i have both options enabled in settings. 

File Type: AVI

Video Codec: Mpeg-4

Audio Codec: MP3

I also tried uninstalling and reinstalling MediaPlayer but still not working

Is your AppleTV connected to an AV receiver, or just a TV? Are you using an HDMI or optical cable for audio?

For audio i use the optical cable and run it to my onkyo receiver

You may try enabling AC3, but leave DTS disabled as some receivers will support one but not the other.  

Tried that already along with doing that vice versa and it did not help at all

I am having the sam problem.

Any update on this matter or has this become a dead subject?

Just wanted to let anyone else whos having this problem know that after i restored my atv2 using seas0npass and reinstalled atvblack and mediaplayer everything started working fine. I am assuming the problem had something to do with upgrading mediaplayer from withiin maintainance becuase after the fresh install of mediaplayer everything is working once again

 

Do you recall the version of AppleTV software you were running when you were experiencing issues?

It was the same as what I am running right now, 4.2.2

Hmm ok. Thanks for the feedback.

I am experiencing the same issue with no audio on 4.2.2. Been happening for a week or so. Restarted Apple TV and lowtide and now just upgraded media player to the latest and no audio. I’m going to upgrade the atv now and get the latest atv flash on it.

do what I did and Restore your appletv using seas0npass then install atvflash. When I was having that problem that was the only way I could get my audio to come back in mediaplayer.

I updated to the latest Apple TV, used the latest Seas0npass, reinstalled the latest ATV and now audio is working perfectly fine with Media Player again.