MediaPlayer 0.7 crashs :(

Pretty much as the title says. I’ve submitted a bug and diagnostics report already.

MP 0.7 shows the media menu, and sometimes the 3 shares I have setup in there, but as soon as I stop on the item long enough (ie, I can get to maintenance if I hit right quickly enough), it locks and eventually the aTV reboots.

This wasn’t present in 0.6.

I’m on AppleTV 4.2.2 - whatever the latest-except-the-one-that-came-out-with-no-JB one is. ATV black. Wired network, talking to a drobo over SMB.

Thanks

So you didnt have this on 0.6? That is odd, most people had this issue with the prevous version, including me. However, I still have it with 0.7.

Using a NAS Qnap 509 via afp, wired. 

Nope. 0.6 worked pretty much perfectly.

I tried removing it, and reinstalling it, but I get the same result :frowning: Might have to try plex or nito…

I have the same issue as this, 0.6 was fine. My shares loaded instantly and was able to go through my small library of videos.

Now with 0.7 when I select the ‘Media’ menu item my atv2 hangs for 5 minutes.

Sometimes my shares popup but clicking these reboots atv2, also selecting settings reboots…

Will submit bug and diagnostics too.

Another MP .7 issue here too.

Wired network, talking to a Mac Mini vis AFP.  I can browse shares fine, it loads metadata normally.  When I try to play any kind of file, MP crashes and the aTV just drops to main menu.  It worked fine before the last update.

I submitted diagnostic info.  Random breakage is very frustrating.

 

Me too, Same issues, had no problem with o.6. 0.7 crashes and causes a reboot as soon as I select a video file to view. As of 1:00pm est the only thing working for me is plex.

ATV2 from quad core mac pro & Drobo via SMB and AFT for XMBC and Media.

We’re looking into a few related issues. So far we’ve found correlation between older AppleTV software versions, and potentially the Plex plugin.

If you haven’t already, please submit a bug report as described in the link below so we can track down these issues as quickly as possible.

My issue as described above persists, and I have never installed the Plex plugin at all.  I used Seas0nPass to jailbreak.

I submitted a bug report yesterday, and will open a support ticket later today.

No plex here. Also latest JBable firmware :frowning:

Only ever has media player and weather installed.

I went back and tried to play one of just about every file extension or encoding type that has ever existed…all the same.  So I submitted another set of diagnostic reports and a support request.  No word back since then.

I got tired of waiting, so I went and re-downloaded the latest version of Seas0nPass and aTV Flash Black and started from the beginning.  I let Seas0nPass download/break a fresh IPSW instead of using an old one, let it sync via iTunes, and then installed aTV and Media Player from scratch with nothing else and added shares.  It works fine now.

I say, under protest, that it shouldn’t have been necessary to do this to remedy a version update for media player. :frowning:  Very disappointing.  But I thought I’d share in case anyone else wants to ‘just fix it’.

 

Thanks Saml, I’ll give that a go tonight, as I have all the bits from last time I JB’ed :slight_smile: re-JB is a PITA, but if it fixes it, it’s an easy PITA.

OK, I re-jailbroke my AppleTV2 (damn, that thing is HARD to get into DFU!), and reinstalled MP, and it works.

Well, it works over AFP. I can’t see the drobo over SMB (which I was using before), but AFP works fine :slight_smile:

So, that might have been the problem. My first 2 items were SMB shares. Works now tho!

Yay!

Add me to the list. The apple tv locks up as soon as i get to the media tab and eventually restarts. I did not have this problem with 0.6. 

Update:

We’ve pinned down a few issues that are causing freeze/crash issues for some users. They’re a bit edge case, but will be fixed in a new version that is coming later this week.

Stay tuned.

Thanks for getting back to us.

 

Note; Since none of the scenarios you mentioned before apply to me, please let me know if there is anything else u need.

 

I hear you, getting it into DFU is just a struggle itself… oddly, I tried the same thing, but my problem still persists.

The scenarios I mentioned before (old AppleTV software and Plex) are actually separate issues. The crashes we fixed are specifically related to updating from MP 0.6 to 0.7.

 

James: OK, but me, and many others had the crashes with 0.6 already, if you look in the support forum.

There are a number of playback improvements we’re working on as well. This week’s version will include a handful of these, but there are still some outstanding items on our todo list.

Hang in there.  :wink:

 

The outstanding issues - do you count the restart issues that I’ve described as outstanding, or inscope of the new release? :slight_smile: