Media Top Row ATV2 iOS 5

I can’t figure out how to disable TV Shows or Music in order to move Media to the top row in the new update. In the previous version I’m pretty sure it was under Settings in maintenance, and it was also under Settings in nitoTV, but I can’t find it anywhere in the new version.

The only thing I found that you can do is under parental control, you can hide iTunes match, which gets rid of music and kicks media up to the top row.

There are a few options.

  1. Disable iTunes Match via Parental Controls - this will hide the Music item
  2. Disable Purchase/Rent content via Parental Controls - this will hide the Movies and TV Shows items

There may be other combinations that work via Parental Controls, but these are the two we’ve tried here.

i just tested the parental controls but i cannot disable just the tv/movie icons. if i disable purchase/rent the icon for music disappears too.

what i want: not movie/tv icons, but the music icon. is this possible? if yes, could you post your parental control settings? thanks!


no help?

Hiding iTunes Match in Parental Controls accomplished my goal, as it removes Music from the top row menu, and I’m not using my TV to play music.

I agree that there doesn’t appear to be a way to disable TV Shows without also disabling Music, as lucx notes. Hiding Rentals in Parental Controls removes TV Shows and Music from the top row menu, which is clearly a bug, since you can’t rent music; the behaviour should be to disable Movies and TV Shows instead. This is an iOS rather than a fireCore bug, though, since it happens on my ATV3 as well.

I posted this is another thread, you can remove Computers to move Media to the top row if that’s an option for you;


Can this method also help to disable TV Shows? I want to remove TV Shows but keep music which I can’t do with parental controls.

Thanks for the help! :wink:

There is a “TVShows.appliance” in the same folder, I’ve never tried but it should work. Rename it to TVShows.appliance.bak and use the restart option in Maintenance and see what happens!


Okay, thanks for your reply! :smiley:

I am really bad at terminal and I don’t know what to do so it would be great if you could help me out.

I entered: ssh

Then I was in the root when I entered password alpine.

I then entered in the path you suggested: /private/var/stash/Applications/

Now I am stuck. Nothing else comes up so I don’t know how I can rename the file.

Would you mind telling me what to put in next to remove the TV Shows icon?

Thanks! :smiley: Really appreciate it! 

Try this when you’re in the /private/var/stash/Applications/ folder:

mv TVShows.appliance TVShows.appliance.bak

Then restart your AppleTV by going to Maintenance -> Settings -> Relaunch AppleTV. Don’t hard reset or you’ll have to do a tethered boot again!

No problem, hope it works for you!

I just tried it and it didn’t work ;(

Comes up with this error in Terminal: mv: cannot stat `TVShows.appliance’: No such file or directory

Is there any chance the TV Shows app is actually called something else in the root?
Why would computers work and not TV?

Thanks for your help so far. I’m sure heaps of people are reading this hoping to get it working too!

I also just did an ‘ls /private/var/stash/Applications/’ command to list all the contents of the folder. It came up with everything in there and ‘TVShows.appliance’ is indeed a file. Why does terminal say that it isn’t a directory? Is it a problem with my connection? 

I also tried to do the same to Computers thinking that it might not allow you to do that to the other two, but I got the same error.

Any way you know to fix this? Can anybody else confirm it working or having the same problem?

For that command to work, you’d have to be in the folder already by using cd.

cd /private/var/stash/Applications/
ls -la (this should show a list of files, make sure you see TVShows.appliance, scroll up)
mv TVShows.appliance TVShows.appliance.bak
ls -la (to verify)


OMG IT WORKED!! Thanks so much! Really appreciate it! :wink:

Anyone who wants to hide one of the top row icons, follow all the instructions that were given to me from jonez

Thanks again! :smiley:

great news :slight_smile: thanks!

No problem glad you got it sorted out!