Media player won't install on v5.2

I’ve just re-jailbroken and put ATVflash on to update to v5.2. All ok. I installed XBMC which installed fine. I then went to install media player but get this error everytime.

e:dpkg was interrupted you must…

I tried a few times, reatarted aTV 1, pulled the power and waited, tried again and same error.

It’s connected wireless but is working as XBMC installed fine.

Any help please.
Cheers

If you can ssh into it just type

dpkg --configure -a… if i remember correctly.

I couldn’t install anything until I ran the command

Not sure what this is I’ll have to google it. Reason I bought ATVflash as its an all in one for stuff like this.

I’ve installed XBMC fine though so not sure what’s going on?

Have you tried re-running the aTV Flash (black) installer from a Mac or PC? Doing this will normally clear up any installation related issues such as this.

I haven’t no, but can try that later. Thanks

ran it again and now installed fine thanks

Hi there, 

I have the same issue. I tried your advice several times with no success. I even tried jailbreaking 4 times before installing AtvFlash.

I am able to download just 1 single add-on via the maintenance menu. After this I get the same exact error.

This is what the log says:

E: dpkg was interupted, you must manually run ‘dpkg --configure -a’ to correct the problem.

 

sounds like there is a package missing. 

My regards, 

 

Angelos

It’s a simple fix.

Everyone should learn to ssh, it’s not too complicated.

If you have a Mac, just use the Terminal.app and type

ssh root:alpine@x.x.x.x (the x’s would be your ATV’s ip address)

accept any prompts and type the command

dpkg --configure -a

followed by

killall -9 Lowtide AppleTV

That’s all, you can try to reinstall any apps on the ATV

If you have a PC, just get a program called Putty and setup an SSH connection with your ATV

 

As I was aware of this solution, I already tried this as well, still, the problem remains…I can install just one add-on and after this I get still the same problem. Besides that, we didn’t buy AtvFlash to be masters in cmds of terminal, did we? :) 

Thanx for the try anyway!

grts, Angelos

These steps are actually done automatically (if needed) when running the aTV Flash (black) installer, or hitting the Retry option when an installation fails. If neither of these resolve the issue you may have a deeper issue, and the best option would be to open a support ticket so we can see what’s actually going on.

Retries wouldn’t work and neither did re-restoring with SP.

Do you think it could be a permission issue, since dpkg --configure -a worked fine when I was logged in as root?

Could be anything really. As a general rule of thumb we try to discourage people from using SSH as there are a ton of anecdotal blog and forum posts on the web that often times feature incomplete (or just incorrect) instructions that can really lead to some unpredictable results. Obviously, if you’re already familiar with SSH and know what you’re doing it’s a different story.

If you want to send in a quick bug report as described in the link above, it will definitely give us a bit more insight as to the root cause of what’s going on.

The suggestion of rerunning the ATVFlash installer cleared the problem.  The problem happened to me after installing XBMC. Thank you for the tip.

I have tried everything in this thread. ssh and a reinstall.

But I keep getting this log file:

E: Broken packages
ts…
Building dependency tree…
Reading state information…

And so on.

Need some help :slight_smile:

 

 

Try this

SSH to ATV and type:

killall -9 apt-get aptitude
rm -f /var/lib/apt/lists/lock
apt-get -y update

When I type it in, it goes like this.

Killall -9 apt-get aptitude
no matching processes were found
Apple-TV:~ root# rm -f /var/lib/apt/lists/lock
Apple-TV:~ root# apt-get -y update

Then it runs through all the packages, and says done

But it still fails to install Media Player on the ATV?

 

Was Seas0nPass used for the jailbreak, or something else?

Im getting the same, really frustrating

 

This is my problem as well. I have tried everything to get it back. It’s the only reason I jailbreak my ATV2.

Same here :frowning:

 

Everything was working fine on 5.0.2, but not on 5.2. I used sn0wbreeze for jailbreak with own SHSH since apple closed their signing window on me, and JB went without trouble.

Any ideas?

EXACT SAME PROBLEM HERE.

Jailbroke with SNowBreeze.

I can install all other Apps like XBMC, Weather, Etc,  cannot install Media Player.

 

Might be time to switch to XBMC   =( 

Error in the Log is:

The Following packages have unmet dependencies:

com.firecore.media: Depends: com.firecore.libafpclient(>=1.3-65) but is not going to be installed

I’ve tried to add the firecore afp client threw NitoTV.  same error

 Fixed My issue by doing the following  (My Problem was related to Snowbreeze JB not loading the AFP Client, which is need for the Media Player)

root# curl -L -O http://apt.saurik.com/cydia-3.7/debs/libgpg-error_1.6-2p_iphoneos-arm.deb
root# dpkg -i libgpg-error_1.6-2p_iphoneos-arm.deb
root# curl -L -O http://apt.saurik.com/cydia-3.7/debs/gcrypt_1.4.0-2p_iphoneos-arm.deb
root# dpkg -i gcrypt_1.4.0-2p_iphoneos-arm.deb
root# curl -L -O http://apt.saurik.com/cydia-3.7/debs/afpfs-ng_0.8.1-2p_iphoneos-arm.deb
root# Apple-TV:/ root# dpkg -i afpfs-ng_0.8.1-2p_iphoneos-arm.deb
root# apt-get update
root# apt-get upgrade 

 

Unfortunately this is related to Sn0wbreeze, as it does not include some of the necessary repos that Seas0nPass adds automatically.

To resolve this without re-jailbreaking you may try the suggestion posted by canadian_mudrunner.

@canadian_mudrunner Nice work. 8)