Media player - video files - .vob-files stuttering all the time


I just updated my ATV2 to beta 7 in the hope that the media player run .vob-files without stuttering now. But it seems so that this problem is still there.

My question: can I do something on my own to improve this?

Background is, I’ve ripped all my DVD’s to VOB-files. Each movie to one single VOB-file (size between 3-6 GB, without quality reduction or else). AVI’s are running prefect.

I’m using a ATV2, FW 4.3, jailbreak with (newest) seasonpass, update to beta 7 via maintenance, update to media player 0.8 via maintenance. I’m using a cabled gigabit network, files stored at a Windows Homeserver.

If anyone has a idea to solve it, please let me know. By the way, XMBC plays it perfect, but I’m not willing to use it.



What type of device are you streaming from? AFP or SMB?

Can you try updating to the new Beta7 version to see if things improve?

Hi James,

sorry for post/reply at 2 frontiers (blog & forum).

Here are (hopefully) all needed information.

Sever: Windows Home Server (based on Server 2003) on a Acer H340.
Network: totally wired, full Gigabit connection.

2x ATV2 as Clients, both connected via SMB!

1st ATV2 running on iOS4.3, breaked with newest ‘seasonpass’, installed ‘beta7’, installed ‘media player 0.8’ (done this morning) = I’ve sent a diagnotic log to you. Serial no.: DCYFF4PNDDR5

2nd ATV2 is running on iOS4.2.2, breaked with older.‘seasonpass’, installed ‘beta6’, installed ‘media player 0.7’= same stuttering. Log Not send. I can do if wanted.

Mainly VOB-Files are stuttering. File size doesn’t matter, each file stutters. In comparison: I’ve tried a 40GB-MKV-File (h264, 1080p), it runs without stuttering. There only appears the normal buffering from time to time.

I used the old ‘DVD Shrink’ to create solo-VOB-files.

With XBMC on ATV2 it runs perfect.

Thanks for your help.

Thanks - I’ll pass along the info and see what we can find.

I’m having the same issue with severe stutter/choppiness, almost looks like individual frames. ATV2, latest ATV firmware, latest Seas0npass, latest MPlayer. Streaming .mkv files 3-6GB from AFP (Mac Pro) The only thing to add to this is that my audio also sounds like it’s slowed down severly to the point of not being recognizable. Also has a high squeal to it. I’ve tried it on TV shows, DVDs, and a BluRay source.  

Would you mind submitting a bug report?

I’ll do that this evening!

Hi James,

any news? Something that could solve the problem?



I’m having the same issue with vob files. No issues with mp4. Just vob

I’m having the same issue with vob files only.




still having this issue… i have tested XMBC wich runs the same files very smoothly. But XMBC sucks and doesnt recognize half of my movies.

Im using clean DVD copys with Ripit to TS folders with VOB files. Just as clean as it can get. The playback is still stuttering and is visible in camera movement/panos wich is basically… always.


So… Firecore! This cant be an issue solvable through bug reports, its an software programing issue in your Media Player. Maybe give the guys at XMBC a call?

They could know ;) 


My idea is that it can be a PAL thingy going on, maybe… but changing tv modes in ATV doesnt make any difference.

Im going to give the latest WD player a shot…


We’re currently working on a number of playback improvements that should improve playback performance for all file types, but will be most noticeable for VOB files. So far the initial performance tests have been very promising.

These improvements will most likely make it into version 1.5.

Sounds great James! Im very happy to hear that :slight_smile:

When is 1.5 likely to hit us please James?