Media Player Shares with Windows 7

Is there anyone that knows how to set up media player shares with smb and Windows 7?  Is it possible to post an instruction set how to do this, or perhaps point me to an existing tutorial if it exists.  I tried searching and have not been able to find anything specific to windows 7 and aTV (Black)

I could also use help with this, the guide seems like its in Windows XP only.

In fact what do I put in for: Share Type, Name, Server, User, Password, and Workgroup.

I use windows 7 and want to share my “Videos” library. I don’t have a password on my user account.

 

EDIT: I got it after fooling around with different names in each of the allotted spaces. I still think the site could use a Windows 7 update.

 

Do you mind sharing your Windows 7 settings and your Media Player Settings, so we can benefit from the collective knowledge?

I would love to know more about those settings as well. I’ve been going through a lot of pages in this forum and the official guide, but a windows 7 outline regarding all those fields would be really helpful.

Thanks!,

A guide for enabling file sharing in Windows 7 can be found here.

That’s the guide I was talking about and I’d be really grateful for a more thorough setup guide. Sorry for the hassle!!

I too am having issues with this.  My media drives are shared and visible to all other networked devices.  Plex and XMBC on the AppleTV see them.  

The ‘add share’ wizard is WAY too complicated on Media Player.  

Let’s dumb it down for morons like me.

Hello… 

I can see my PC from ATV2 but when I test connection it shows a message 

 

" Coul not open dir [//smb:…-PC]. Reason: Permission dennied (13)" 

 

Is anyone can help me with that?  I’ve already click share on folder and allow for everyone. I have windows 7

 

One hint that got me going. If you have a user name…you MUST have a password! Once I shared the desired folders it was an easy setup.

Hi,

 

To share correctly with windows 7, you need to go on your folder that you want to do it, and right click and --> properties --> Share --> advanced sharing --> permission --> Everyone

and mark selected “Total control”

 

It should be work.

Perhaps restart your computer.

aTV Flash Media Player for Windows 7 64bit.  I got it working. Here’s what worked for me:



To get past the first obstacle: Could not open dir [smb://XXXX-PC]. Reason: No such file or directory.



On aTV Media Player, I just kept the settings as they automatically showed up:

Share Type:  SMB

Share Name:  XXXX-PC (automatically showed up, my Windows 7 PC name.  Didn’t need to enter IP address)

Share Server: XXXX-PC (also showed up automatically, same as Share name)

User: left blank

Password: left blank

Workgroup:  Workgroup (also automatically showed up)



At this point, I test the connection, and it still fails…



Then on my Windows 7: Control Panel -> network and sharing -> change advanced sharing options -> turn off password protected sharing.



Now back to the aTV Media Player, and the Test Connection says “Passed.”  But, when I open up my PC on aTV Media Player, there are no items to be seen.


So, back to Windows 7. I go to each folder I wish to share and: right click Properties -> Sharing tab -> Share… -> add the name “Everyone” and set Permission level at Read/Write -> Click Share Button.


Then back to the Sharing Tab. Advanced Sharing… -> Check the “Share this Folder” box -> Permissions -> Click Everyone -> Click “Allow” box next to “Full Control” -> Click OK to close window -> Click OK to close the next window-> Click Close to close the final window.



To check if the folders you wish to shared are all being shared on Windows 7: On the Desktop, Right-Click “Personalize” -> Change desktop icons -> Check the “Network” box -> Click OK to close window -> Double-click the “Network” icon on desktop -> Double-click your Computer.

Your shared folders that are being shared with the aTV should all be proudly displayed.  Along with your printer, but who cares.



And now, at long last, these same folders (minus the printer) show up on my aTV Media Player.



Tip:  I found that if I did these settings for each head folder (My Pictures, My Videos, My Music), then all the subfolders within would just fall into place and be shared also.  The same goes for my USB external hard drive.



I hope this helps someone, anyone.  It took hours of trial and error to get this to work, and it’s astonishing that there isn’t a more thorough manual posted other than the laughably spartan “guide” that firecore supplies. (re-pasted here, for your frustration http://support.firecore.com/entries/20655156-enable-file-sharing-on-a-mac-pc)