Media Player DVD Playback error

Hi, I have already submitted a Support Request.

Has anyowne the same issue with DVD. Currently I can not play any kind of DVD. I always get DVD Playback error.
All installed Software is up to date.

ATV 4.3 jailbreaked with the newest SP.

However, the old Apple TV don’t show up this issue if I stream a DVD.

Which tool was used to backup your DVD files?

If you opened a support ticket and submitted a diagnostic report from you AppleTV we will look into what’s going on.

Hi James,

 

I have already submitted a support ticket - request (#18888).

I used Mac DVD Ripper and MacTheRipper to get Video_TS (VOB). However some files were backed up by friends and there software I don’t know.

Ok, we’ll dig into the logs and see what we can find.

For fun, you may give RipIt a try to see if you have more success.

http://thelittleappfactory.com/ripit/

Thanks James for your fast response and the Software reccomandation - I will try it.

In addition I have now installed the new Maintainance Release. I will let you know if its now fixed.

Hi, the new Maintainance Release solved the issue.

Thanks for your fast troubelshotting.

Hi, I’m having the same issue trying to play DVDs ripped from RiptIt and stored on my Netgear ReadyNAS over SMB share. I can see all the movies in media player and it pulls the metadata just fine, but when I try to play them they result in the “playback error has occurred” message.

I made sure I updated Maintenance and Media Player to the latest within Manage Extras submenu.

I also tried to submit a ATV2 report, but each time I submitted it, it rebooted my ATV2, so I don’t know if anything was actually sent out or not. Is that normal behavior when submitting the system report?

Thanks for your help!

 

Hmm - which version of AppleTV software are you running?

iOS 4.3 (2557) Serial: C0KF44Z0DDR5

Thanks.

Ok - can you try updating to today’s Maintenance release to see if that resolves the issue?

Hi James, I just updated, but it didn’t fix my issues. I was however, able to send the report without crashing this time and got a “report sent successfully” message. Hopefully that will help pinpoint the issue. Thanks.

Well that’s progress at least.  :wink:

I found your report so we’ll see if we can figure out what’s going on.

same issue …same  same same all ripit back ups fail…non ripit back ups (mpeg-2) work…

one other thing in when listing the movies  the ripit backps have the title then a square/rectangle with a x in it …?

Can you provide a few example file names you are having trouble with?

RipIt media (with and without the .dvdmedia extension) is working here.

Hi

First of all thanks for this wonderful software I’m sure it will be fantastic when you get fix some of the bugs. I know you are working on it.

I’m having trouble playing some movie, they are all I video_TS folders. All the movie I can’t play on your media player are working in XBMC, but I don’t want to use XBMC so I hope you can get it fix

 

I Rip my DVDs using AnyDVD with DVDShrink to TS_Folders on Windows /

Apple TV software is 4.2.2 (2203)

I submitted a report

#19732 error video_TS folders diagnostic serial: DCYFKUV4DDR%

Jut a thought - I would expect the folders to be AUDIO_TS and VIDEO_TS  (i.e. all capitals).  Not sure if this matters or not, but it might.

I have the same problem using the Mediaplayer.

DVDrips are places in a SMB share on a NAS in the following structure

-Moviename
  -AUDIO_TS
  -VIDEO_TS

DVDrips is done using AnyDVD and CloneDVD.

When browsing the share metadata and covers is fetched without problems but when I press play I get the playback error.

diagnostic Serial C07G6BH9DDR5
ATV ver: 4.3 (2557)
OS: 4.3 (8F455)
Firecore Beta7
Mediaplayer v0.8-144748

I have done a quick test. When the movie is placed on either of my NAS (Freenas or Qnap) i get the error but when I copy the same movies to my homeserver playback is okay.
Could be a problem accessing smb shares or maybe a security problem. I think my SMB shares i read-only. But when testing on the homeserver I had full access.

Will do some more test later.

Of course, you’r right. Guess I hit the submit button a little to fast.

Hello

Brian5114

Do you movies work in XBMC? All my movies work fine in XBMC so I think the problem is the media player having problem supporting TS Folders