Media player don't display 'Ö' in subtitles

Strange one indeed!

In the Swedish language we use åäö in addition to the ‘english’ character set.

And Media player copes fine with all these within subtitles in lower case, but in upper case the Ö disappears while ÅÄ works fine?

I’ve tried subtitles in both Latin and UTF8 and the behavior is the same.

I don’t think it has been like this from the beginning, but I can’t remember after what version I noticed it first.

To better handle Swedish characters you may try adjusting the subtitle encoding type as described here.

Hi James,


Believe me I’ve tried… :wink:

And as I described, it does work with just one characters exception. You could say that the Media Player have a character flaw!

And I do believe this issue is something that have appeared somewhere around the 1.3-1.5 time frame, since I don’t remember seeing this before. And when the issue appeared I just assumed that the subtitle file was bad, but then I could see the pattern, I’ts only the capital ‘Ö’ that’s missing.

Then I could verify that that the same .srt file contained the right character, both by checkin it out with a text editor and by playing in VLC.

I have attached a small test file for your enjoyment! 8)

Hmmm…interesting. I’ve just tested that file here and am seeing (or not seeing rather) the missing Ö as well.

We’ll take a look and see what’s going on.