Media Player -> Connection Refused (61) error while connecting to shared drive on windows

I have been accessing my windows shared drive using Media Player until this morning, before I had to format my machine. But, immediately after the format (system name, share drive name, user details are same as before format), I am unable to connect/access to the share drive. I did try to setup a new SMB share, and test the connection, but still getting the same error as below

could not open dir [smb://PARI]. Reason: Connection refused (61)

Please advice on what could be the issue? I did enable the file sharing etc on my pc.

Having the same problem since yesterday, I thought it was because i changed my wifi router but everything is pretty much identical to the old router.

I´m having the same problem. I´ve tried restoring the ATV and jailbreaking it again and setting upp atv flash but I get the same error. I have also checked all my shared folders and i can access them on other computers. 

Even I tried to reformat Apple tv with new season pass and reinstalled atv flash, but still face same issue…
I did raise a service request more than 2 weeks back, but no concrete response yet except for asking a lame question every 1 week and staying quite after that…

I do hope they are working on a solution because the ATV is now pretty useless for me. 

having the same issue. i updated my system to 4.4.4 and the new atv black but now i cant access my shares.

I got mine going last night by putting workgroup in the workgroup entry. yeah sounds simple but everything seams to be functioning now. hope it helps

Didn’t quite get it… How do you add workgroup into workgroup. I am on windows vista home…

I fixed the problem on my end by formatting my computer. A bit harsh but it seems to work. I got XBMC streaming and the media player too. 

Having the same issue as well with 1.1.1 accessing from QNAP SMB share.  Never an issue before.

I am having similar issue! 

Upgraded from tethered to 4.4.4 untethered fw and as i try to open my shares(they are located through manage share option) i get the following message 

Could not open dir[smb://******/music]. Reason: Permission denied(13)

This problem occurs only for the shares that are located on external drives on my computer. No problem when opening shares on pc hard disk!

 

Strage thing is that installed the XBMC as well and can stream files that are located on the same external hard drives without problem!

 

Any suggestions?

Same here - Using an LSCHL buffalo NAS 1tb on the same switch as my atv flash black atv2, it doesn’t want to know, passworded or not - it sees the shares but simply doesn’t play ball once you try to browse. On my normal big ugly appleTV1 running their latest version it works fine. Even on xbmc now I get ‘operation timed out’ for my smb shares. It’s obviously something very simple, but if I replace the NAS with an old asus eeepc 901 with ext. usb drive it works fine. With everything else on the network it works fine, and the NAS works fine with all other devices apart from the ATV flash black. It doesn’t give any clues to what the issue is, it just don’t work. These problems only appeared when I upgraded, and when I was showing my mates how great it was. Felt like a right tool! "hahaha that’ll teach you for jailbreaking it’ - let’s hope someone reads this who can prove otherwise …