Media Player 2.0 Subtitles Glitch

I updated my Apple TV today, it’s a great upgrade for Media Player!

However, playing my usual TV Shows and Movies in 480p and 720p MKV with SRT external subtitles, I noticed a glitch, a certain type of jumps in the video when a subtitle appears on screen; causing little jumpings all over the video when a subtitle pops up. Very annoying.

I tried to fix it by changing the color, size, and outline of the subtitles and nothing… even with MKVs with a lower bitrate.

I hope you can fix it as soon as possible on the next update.

Hmmm, I wasn’t able to replicate the issue here. Probably best to send in a bug report so we can look into it.


Ok, I have submitted my report ticket.

I have the same issue.

Since ive installed version 2.0 Black, when i watch a movie or TV series (from library AND from remote files) the scenes Flicks as the Subtitles appears. When i turn off the subtitle, the movie runs smoothly.

Ive watched several episodes and movies to test. All the same.

If i use XBMC instead Native ATV MEdia Player, the problem goes away.

Can i go back the previous version? Is there any workaround or procedure to stop the annoying flicker?


I have also noticed the same problem. Little stutter in video playbak that was not there in version 1.7.

I regret i upgraded to this version. Why is it not possible to downgrade to an earlier version of aTV?

In the last minor update THE PROBLEM STILL THERE.
Please give the option to us to downgrade to 1.7 until the problem is not solved.

Its pointless have the library feature if foreigner and deaf costumers cant watch their movies properly

The Glitch is ANNOYING! And happens in ALL KIND OF VIDOS (Mkv, avi, mp4, m4v, 480 or 720)




I agree with Adborges here. I have also raised this point with FireCore support. After a few days they came back to me stating that they cannot reproduce the problem and if I can send some sample files.

I am currently on a business trip so I cannot do this. Adborges, can you do this?

@James, I would prefer to get the option to downgrade to 1.7. You can then take your time to diagnose this issue. I just want to watch videos without stutter. Please provide us with a link or option to reinstall version 1.7. PLEASE!

It’s been 2 updates for Media Player but no one seems to solve the issue.

I updated Media Player 2.0.1-358. The problem is still there.

I don’t know what to do. I tried to search the .DEB package of Media Player 1.7 via SSH to replace the app but I couldn’t find it.

I have restored my Apple TV, jailbreaked it again, and installed Firecore but nothing…

I’m not able to watch videos without that flickng when a sub is on the screen!

Hi CrisVida,

I have filed an error report with FireCore support and they have asked me to send a sample file. I did that yesterday. Hopefully they can find the problem. I suggest you to send them some sample file as well. Firecore support claimed they did not have sample files from anybody else to diagnose this problem.

As for the .deb files…watch your inbox.


We’ve replicated the issue here (thanks to jjjdewijs’s sample) and are working on a fix.

Sorry for the trouble.

I’m also seeing the exact same behaviour, as reported in this thread…


any update from the support staff, this is really irritating… :confused:

After three months we’re still waiting an update.

Is this issue fixable? It is very, very annoying to watch everything choppy with every video with subtitles.

Come on Firec0re, still nothing on this?


It was back on October 4th that the support staff managed to replicate the issue and still about two months ahead no apparent fix has been issued…what’s taking so long?! I’ve abandoned watching either movies or series on the big screen because of this, back to the 15.4’’ laptop screen and let me tell you I’m not a happy camper at all. :confused: At least provide us with a status update, a clue, something…


[edit] it is shown here that an update’s been issued on the 26th of November which puts this a few days ago…However MediaPlayer is still at version 2.0.1-something, Maintenance’s been updated to 2.0.2-6 if i remember well and yes the sub stutter issue is STILL alive and strong… [/edit]

James, is there something going on in your company? I see less responses from yourself than usual.

It has been months since this issue was reported and you confirmed that a fix is available. I see also many people having problems with memory issues. Why is there no update released yet?

Due to the fact that there is no downgrade option, we are no stuck with a piece of software we paid money for and doesn’t work properly. Should we now all go away and look for alternatives like Plex?

Come on, just give us some status updates? When can we expect an updated version with fixes? Why is it taking so long?

Sorry for the delay, but we’ve been working hard to fix this issue, as well as a few other bugs that have come up.

The current plan is to have a major update with number of new features, along with an equal portion of fixes available in early January.

Dear firecore we’re slowly heading towards mid-January…according to your statements right around this time point there should be a new release for the MediaPlayer, supposedly for the whole suite, too rectifying this sub stutter once and for all, as well as adding other bells & wistles…


so…how’s that progressing if you don’t mind me asking?

We’re stil on track to have 2.1 ready within the next few days…hopefully this coming Friday.

Ok folks. The fix for this issue is now (finally) available in version 2.1 which was just released.

I’m glad to report that upon brief testing it indeed seems that this particular issue has finally been fixed! Will look into it further and report back after I’ve performed more testing in the next couple of days.


One thing that still bugs me and is somewhat related to the subtitles is that even when a movie is paused in entering the sub selection screen there’s a drift in the timeline of the movie upon return which obviously suggests that the movie progresses in playback in the background while the sub selection / download takes place…kinda hoped that this would be looked into, too…might have missed reporting it myself first time around though…


in any case kudos to the devs for fixing this albeit it took you guys AGES to do so…

Great, glad to hear it’s working again.

Really sorry for the delay in getting this fixed. Due to the nature of the 2.1 update, and the number of moving parts it just wasn’t possible to push a small fix like this out by itself.