Media Player (1.5) causes ATV2 to reboot when fetching metadata


I’ve put in a support request, but it’s going on a week now with no reply…

I have one particular TV series that, when attempting to fetch the metadata for any individual “Season” folders, my ATV2 crashes and reboots.

I’m relatively sure it may just be a matter of something being corrupt - the series exists on thetvdb, and I am able to fetch the data successfully with other apps like XBMC, Plex, and even 3rd-party stuff like Ember Media Manager.

Is there away that I can “clear out” what my ATV may already know about this series?  Meaning, if this issue is due to corruption of something it may have already fetched/downloaded related to this one TV series, is there someplace in the file system of the ATV that I can go to delete that and try again as if it were “new” - without wiping out anything that was already grabbed for my (properly working) movies and shows?

Thanks in advance…

The other possibility is that it is one of the video files for the series that is corrupt (I know from experience this can cause a crash).   It might be worth moving them out of the folder, and then moving them back one at a time to see if it is a specific file that causes the problem.

Thanks for the suggestion, itimpi.


Unfortunately, it didn’t work.  I tried removing files one by one, as you suggested, and even went so far as to move the whole “top level” directory for this series out of my “TV Series” path, reboot the ATV, re-create the folder, re-create one season folder, and move a “known-good” (played fine with VLC and in XBMC) file in to the folder.  Poof - crash, as soon as media player tried to fetch the metadata.

I still suspect there is information about this series saved somewhere…  Even after doing all of this, the fanart still showed up for it, despite my not putting a ‘folder.jpg’ back in the directories that I re-created.  If I could figure out where any info about this series may be saved (and delete it), I tink it could help…  Any thoughts on that?

So, I was really determined to fix this.  The best I cold do is a work-around, which may or may not be helpful to anyone else, so, here’s what I’ve done to get around it.  It’s not perfect, but at least I can open the folders without mediaplayer crashing now…

First, I changed the “content type” to “None” for the top-level folder and each of the season folders

Next, I re-muxed the mkv files, embedding the Title of the episode in the “Title” tag

Then, I replaced the original MKVs with the remuxed (title tag added) files.

Now, I can browse the folders in mediaplayer, and properly display the episode titles.  Of course, now that the content type is “none”, I can’t download the episode descriptions (so, like I said, it isn’t perfect), but at least it isn’t crashing anymore.

Still, I’d like to get to the root cause, and eventually get it fixed so I can get this series consistent with all my other TV shows…