Match Framerate not working proplery

So I decided to get the new ATV after all. However, I noticed that match framerate does not work properly for all content types.

The problems I encountered are:
-video with 24.000 fps gets outputted as 23.976
-video with 60.000 fps get outputted as 59.94

Both result in stutter. I tested it with latest infuse as well as MrMC, both having the same problem.
So is this because Apple forgot to implement the framerates 24.000 and 60.000 or is this something you can fix?

Sample for 24.000 fps:!AgROFInHQckxxyl-DaS9qO1KCDaJ

Samle for 60.000 fps:!AgROFInHQckxxytbjW13VguD5Xqv

I found a thread over at MrMC where two other people reported the same. An employee suggested to contact Apple.
Nevertheless, an official response from you would be appreciated.

1 Like

AFAIK, the Apple TV does not currently support 60.000 or 24.000 output.

Typically, when Apple (or most anyone else) markets a feature as 60fps or 24fps, what they really mean is 59.94fps and 23.976fps - round numbers are simply less confusing for most people.

I know at least a few people (including one Apple employee) have submitted suggestions to Apple regarding this, but considering most commercial content is mastered in 23.976/29.97 I don’t imagine it’s going to be very high on their priority list.

1 Like

Thanks for your input. Yeah it’s true that only a fraction uses this framerate. However, this should be easy to implement for them.
I’m absolutely stunned that nobody reported on this when Apple introduced the match framerate feature.
For me it’s an absolutely basic feature.

A year has gone by and still no support for 24.000 or 60.000. That suggests that either a) the hardware is incapable of it or b) Apple don’t ever intend to enable this for some unknown reason. It would be very good to know which - if the latter then maybe Apple will be persuaded sometime - after all they added frame rate matching.

I bought an ATV4K knowing about this issue but believing, like apparently most people do, that 24.000 content is very rare. Then a few days ago I saw a post on AVForums suggesting that all movies on Netflix were encoded in 24.000. I don’t know if this is correct or not but it it is, it puts a very different slant on things. I’ve only watched one movie on Netflix since I bought the 4K (Bird Box) and I could definitely see the frame skips.

BTW I tested various frame rates on the ATV using Infuse, MrMC and VLC. I saw the skips on the 24.000 and 60.000 tests with MrMC and VLC. However with Infuse the playback was very bad - lots of breaks in the playback. I was very surprised about this. I’ll do the test again when I can prise the remote from my wife’s hand.

The test videos are freely available - they show vertical white bands moving left to right on a black background.

Yeah I’ve noticed a growing number of Netflix titles appearing in 24.00 frame rate,maybe it’s a good thing that might push Apple to fix this. It’s these small niggles that still separate app streamers from genuine media players like dune etc.

Yup I was the one who brought it up on AVforums about Netflix movies being shot in 24.000 fps and their TV shows shot in 23.976 fps. I still don’t understand why Netflix are using 24.000 fps for their movies when every other studio uses the standard 23.976 fps, so strange.

Fingers crossed for a future TVOS update along with Atmos support for infuse, plex…etc

James any word about 24.000 fps being supported soon? I remember a month ago you said you heard it maybe coming soon but no eta.

As TVOS13 has been announced, has it been possible to check if true 24p (24.000) output was included in it ?
Kind regards

Anyone who knows whether tvOS 13 has support for 24.000 fps?

On my Apple TV 4K running tvOS 13.3, the playback of 24.000 fps video still skips a frame every once in a while. It seems that more and more new movies are in 24.000 (instead of 23.976) fps.

Unfortunately this issue is still not fixed. So maybe it would help, if Infuse could show next to resolution the frame rate of the video. This will of course not fix anything, but it would prevent me from watching movies with strict 24.000fps with the Apple TV.

You can find out for yourself if you watch Netflix via a browser on a PC (and presumably Mac). While watching, hit Ctrl-Alt-Shift-D and a video overlay is displayed with lots of info about the content, one of which is frame rate. I just checked this now and Netflix suggested I watch The Witcher, and believe it or not this is encoded at 24.000.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.