Match frame rate/dynamic range crashes either Infuse or AppleTV

I’ve tested this thoroughly before posting.

I have a 4K AppleTV linked to a brand new, high end Sony X90F via a Belkin ultra high speed cable. The pair can connect happily on 4K Dolby Vision 50hz, HDR and presumably all the lower settings too.

With the AppleTV on 4K Dolby Vision or 4K HDR, Infuse works fine so long as the video settings ‘match dynamic range’ and ‘match frame rate’ are set to OFF. When either of those settings are turned ON, I get a crash on playing a movie and the TV reports ‘no HDMI signal’. It’s as though the entire AppleTV has crashed, although the remote still seems to trigger the AppleTV’s LED indicator and I can sometimes exit to the AppleTV main menu.

To be clear, this is NOT the normal brief change to black screen that happens when the AppleTV shifts video standard. It stays black. It doesn’t come back no matter how long I wait.

Restarting the AppleTV doesn’t work. Doing a full restart of the Sony TV (which runs on Android) DOES work for a while, but it flakes out again. I’m on the latest version of Infuse, TVOS and Android TV.

Also, in case you’re wondering: I want to turn ‘match dynamic range’ and ‘match frame rate’ on for picture quality reasons. The video playback quality when left on default settings looks washed out and too low in colour saturation.

This sounds like a hardware or handshake issue. Try with a new cable. Additionally does the same thing happen when watching content in other apps with match options turned on?

Thanks Jarvis. I’m actually using a new cable. The AppleTV had problems with an earlier, lower spec cable that was allegedly HDMI 2.0b but could only do 18 Gbps. The new one is 48 Gbps. There’s no upgrade from that.

I did test Netflix out on the AppleTV with the matched settings and it worked OK.

To be honest I’d be more likely to blame the TV, but I’m posting here to see if any others with the 2018 generation Sony TVs are getting the issue.

Just to tick all the boxes have you upgraded the firmware on the TV?

Yes - as per my original post.

The recommended settings on ATV 4K should be 4K SDR 50/60HZ according your contry and match framerate/dynamic range should be on. Try with this settings and DV/HDR will be engaged only with proper video files/streaming. Keeping DV engaged all the time would not be that good for the TV (overburn may appear).
I have the same setup initially and now atv4k is going through soundbar HT-ZF9. No issues at all

1 Like

I have to be honest - coming back to the TV tonight, I can’t reproduce the problem. I’m assuming some glitch at the HDMI driver end on the TV.

Your advice was on the money though. I switched the base video setting to 4K SDR and left Frame rate and Dynamic Range matching on. It switched up to Dolby Vision when it needed to play that content. It then dawned on me that this is what the Sony TV does itself - its home navigation screen is definitely 4K SDR, and it only switches up for content.

Thanks for making my experience a lot more enjoyable guys!

1 Like

Hey Dandemon,

Did you never recognize this problem again? I have same issue with a Samsung TV. But everytime i fix it with try and error method change hdmi, …, works for a while (about 2-3 weeks) and then i have the same issue again. I think too it’s something with the settings “match dynamic range” and “match frame rate” because after switching to black screen, the screen doesn’t turn on again.

Can you tell what exactly you have done, to fix this permanentally? Only difference i have in my settings is i have 4K HDR than 4K SDR set. Can’t this really be the cause?

Thanks for your reply and any other help is welcome.

If the native mode for your tv is 4K SDR then I’d say keep the setting at 4K SDR and let it switch to HDR only when needed. It wouldn’t hurt to try it for a few weeks and see if that stops the problem.

This is what worked for me. All has gone without a hitch since then.

But why should be the native mode of a tv which was released in 2018 4K SDR and not 4K HDR?
When i change the settings the picture for example in screen saver mode of apple tv is not as good, because it’s just 4K SDR. Does somebody know, when exactly does apple tv change to HDR, with setting “match dynamic range”?

My guess is that running HDR is a bit more taxing on the panel and SDR increases the life of the panel. For your second question, google is your friend.

After googling your exact question, the first response is

Basically, when your content is HDR it switches to HDR and if your content is SDR then it stays in SDR.

It’s probably some sort of software issue with either your TV or the Apple TV. I have no issue running in HDR/Dolby Vision on my LG OLED as the main display driver. I’d definitely recommend filing a bug report with Apple and your TV maker.

[quote=NC Bullseye]

My guess is that running HDR is a bit more taxing on the panel and SDR increases the life of the panel. For your second question, google is your friend.

After googling your exact question, the first response is

Basically, when your content is HDR it switches to HDR and if your content is SDR then it stays in SDR.[/ quote]

The answer can‘t be right, because screen savers are hdr it stays in sdr. YouTube some movies are in hdr it stays in sdr and the articke does not give an answer, when exactly it change the dynamic range.

Can you provide an Apple source that states the screensavers are HDR files? The only sources I’ve seen have determined the aerial screen savers are in DV or SD.

And as I stated above and as verified in the Apple tech article it switches to HDR when a player (like Infuse) plays a file that is encoded in HDR which is exactly what happens when the settings are set as recommended above. As to youtube or any other streaming service I can’t address how they provide their content.

I agree with the above. Having used the AppleTV a while I certainly don’t want HDR for general menu use etc. I still think Infuse should be fixed to work for those who want otherwise.

For example, on the 2015 Sony TVs you need to set AppleTV on HDR all the time or you won’t get Dolby Vision through the Netflix app. That’s a legacy issue and it’s nothing to do with Infuse - I just mention it as an example of users who need to default to HDR and may get the problem in my original post.

Know i buy a new hdmi cable and setup the apple tv as descriped above. I thought problem is fixed.
But yesterday i run in same issue again. Any other suggestion how can i fix this problem?

Go to settings and then Storage and Reset and do a factory reset. If you haven’t done this already of course.

Hope that helps.

Sure i did this. Nothing helps.

Does the crash happen in other apps such as Netflix?