Many things not working in 3.3.3


I’m new to using the ATV Flash tool but it seems to me that many things are not working as intended. I tried using version 2.1 and 2.2 of the Apple TV OS but Sapphire, ATV Files, and Media Cloud do not show up in the menu items even though the ATV Flash installer says they are included. What is going on or what am I doing wrong??

Additionally, I followed the instructions ( for adding keyboard, USB hard drive support, and SMB support to the Apple TV but I tried 3 different keyboards and none of them will work. Are keyboards supposed to work during all menus or only certain menus?

Furthermore, streaming DVD playback (unconverted VIDEO_TS folder) from a NAS drive is terrible over a wireless N network. The playback is choppy the Apple logo often appears on screen briefly. My windows media center has no problems streaming video from the NAS drive location so why can’t the Apple TV using Nito TV? The Apple TV was even having problems playing H.264 files from the same NAS drive and I thought H.264 was a standard supported file type on the Apple TV?

I don’t want to request a refund because I want these features on the Apple TV but if they are not going to work then I don’t think I should pay for them. Any help getting these features to work would be great. Is an updated version of the ATV Flash tool coming out any time soon to address these issues?

I realize that the creators of the ATV Flash tool are not directly responsible for all the features in the installer but if they are listed in the installer I would expect them to work.

Two things you can try:

  1. Adjust cache time in: DVD > Settings > Cache Time
  2. Change playback mode to Quicktime or Mixed in: DVD > Settings > Playback Mode