Manual, Non-Installer aTV Flash Installation?

I’ve had enough trying to get iTunes and ATV2 to see each other on Home Sharing. My only non Linux computer is my work laptop and I assume that the Firewall settings that Im locked out of are preventing the proper communication.  I have no problem with reaching the ATV by SSH. Tried manually transferring then installing the .deb package from the Mac version of aTV Flash installer in the Payload.tar but Im guessing this isnt everything as there is only 1 .deb file and nothing happens when I do the install. Has anyone been able to successfully install aTV Flash black by SSH? If so please pass on your method. Thanks

I second this request. This is frankly a ridiculous software delivery method that means you need to pre-install a load of otherwise useless software (iTunes and Bonjour) and set up an Apple ID to enable home sharing (Tip: order a free iPhone game to enable you to set an account up without payment information).

Once all that lengthly fiasco is finished you are left with no useful debugging information if you have connection problems between the Apple TV 2 and the PC.

If anyone can suggest an SSH or direct USB install method I’d be very happy. Otherwise I think I’m sadly going to have to seek a Paypal dispute for a refund.

The upcoming Beta6 version will include an option to manually enter the AppleTV’s IP address to install aTV Flash (black).

Basically the installer will search for AppleTVs on your network, if it doesn’t find any (missing Bonjour, iTunes, etc…) the installer will prompt you for the IP address which can be found on the AppleTV in the Settings --> General --> About menu.

Fantastic news!

Is there an ETA or somewhere I can get a nightly build with that fix in?

Unfortunately we don’t have a nightly build of the installer available.

Beta6 should be available later this month.

Hello, i am new here and from Holland. My Englisch is not so good. Sorry for that. 

I have bought te APTV2 and it is working fine. It works with my iTunes on my macbook Air and it also works with my iPad. So filesharing is on  and also airply is on. I Hyjact the aptv2 succesful. But when i try to put aTV Flash on my aptv2 it says that it can not find my aptv. I must enable filesharing and airplay. But that works alright. It dit not ask for an ip number.

 

what do i wrong. My modem is a sitecom and do not work with bonjour. 

i found the problem. It dit not worked while the aptv2 was on wifi. when i whired the aptv2 it installed in a moment.