Maintenance update

I am in the process of trying to do the latest maintenance update but it seems to be taking a long time.Can anyone tell me if it is a large update or is something else wrong,i have checked that the internet is working fine so any info would be greatly received.



I have the same problem, looks like the server is down…

Same issue :frowning:

Same here… I am not able to install, update or remove anything …

Yeah same here with 1.2 update.

Same here. ATV Flash and XMBC both show in the maintenance menu that there is an update available, but when i try to install it freezes at “installing maintenance”.

Also here

same for me, when i try to install remote HD, there is nothing just the spinning logo…

This issue is actually related to some of the default (cydia) repos that are installed on the AppleTV.

Since the iPhone 4S and iPad2 jailbreak came out, these repos have been getting a lot of traffic which is resulting in some slowness.

If you let the install run its course it will complete eventually, though it may take a bit more time than normal. This issue should resolve itself soon.

For me it’s OK now. I have just restarted my Apple TV and everything was there.

Thank you for the tip, i tried it again and it updated both maintenance and XBMC. It took a little bit longer as usual tough.

It’s now running.


I can’t update anything Jan 24 2012

My problem is a little different. Tried installing xbmc update from the aTV Flash(black) menu. I get message that the update has failed and the “E:dpkg was interrupted, you must manually run ‘dpkg – configure - a’ to correct the problem.”

How do I run this manually?


This issue can be cured by re-running the aTV Flash (black) installer from a Mac or PC.


Thanks, I’ll try that. But will re-running the aTV installer wipe out all my previously configured programs like xbmc and its setting and library? 

Nope. Re-running the aTV Flash (black) installer will only re-install the Maintenance item, which will clear up any errors you are seeing.

Your settings and other plugins will not be affected.


Excellent, James, and many thanks for the quick answer. I’ll try this just as soon as my wife will surrender the TV for a moment.

I get “Sorry, the installer could not install Maintenance (Error 4.2).” when I try to reinstall the latest version.