macOS sharing / login problem

Hi,

  1. On my MBP I enabled File Sharing, using SMB protocol and added the folders I want to share to the Shared Folders list (“Movies” and “active cam” specific folder). Why on my ATV 4K do I see (and have access) to my Macintosh HD and all user’s data?
  2. I’ve got problem with login. After many tries “Your username and password combination isn’t right. Please try again” I found out It works only when I go to system preferences, choose Sharing. File Sharing is “On” with a green dot in front, go to Options, SMB is checked. I must check the “On” box to the left of my name, get a prompt for my name and password. But it says that it requires storing the user’s account password on my computer and is less secure. Is it really necessary?
  3. In tips I found:”You cannot type spaces as part of a share name when connecting. In place of any space in the share name, use %20”. But it doesn’t work for me. It works with space but I must follow steps from point 2.

Cheers, Michael

There are a few things to check.

  1. SMB is enabled on your Mac (more info here https://support.apple.com/en-us/HT204445).
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above).
  3. Selected username and password are being entered in Infuse.

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: https://support.apple.com/kb/PH18695

James,

  1. Yes, SMB is enabled on my Mac. The question is why I see also folders not listed? Looks like full access which I don’t like.
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above). OK, but why? I use only Apple devices. Is it necessery to grant access this way? (wich is less secure).
  3. Selected username and password are being entered in Infuse. OK, clear. What about space between name and surename in my login - can I leave gap/space or need to replace with " %20"?

Michal

Hi Michal. I shared your concern (I do not know if it is justified but anyway).
My solution is to use NFS sharing. That is only viable on a fixed computer on your home network.

With NFS, you control access by folder, not according to users but IP addresses (which is OK for me on my home network, I just make sure to allocate fixes IP addresses to all my devices).
And you can authorize read-only access.

It looks complicated, but is actually pretty simple with a software called NFS Manager, which you can fully use freely and is available here: NFS Manager: Description
It works perfectly with Infuse, and since I only share video folders, and in a read-only way, I am very OK with the IP-only access restriction.