Macbook going to sleep?

Hi!
I used to have the Plex app on ATV to watch stuff but using infuse now … I used to have 0 problems with Macbook Air sleeping …
Was it because Plex was transcoding thus waking up the mac?
What is the recommended practice ? I could use amphetamine to set up sessions and uncheck “let mac sleep when cover closed” …
Is there any specific trigger I could set up?

thanks

Welcome to the forum!

One thing that can help in this case is to add the MAC (Media Access Control) address to share settings (under Advanced) in Infuse. Doing this will allow Infuse to use an option called Wake-on-LAN (WoL) which will allow your Mac to wake up automatically if it goes into sleep mode.

Your MAC address can be found in macOS System Preferences > Network > Connection Type (Wi-Fi, Ethernet, etc…) > Advanced > Hardware

you mean in network shares right?
even though I put the right user/pass it says combination is wrong …

There are a few things to check.

  1. SMB is enabled on your Mac (more info here https://support.apple.com/en-us/HT204445).
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above).
  3. Selected username and password are being entered in Infuse.

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: https://support.apple.com/guide/mac-help/set-up-other-users-mtusr001/mac