Mac OSX Lion share issue - Cannot find SMB Shares

Hello All,

I am suffering a problem where I can no longer find the SMB shares on my Apple TV 2 now that I have installed Mac OSX Lion.

I have seen on other posts that there is a work around useing macports and Xcode.

This is a very long winded and seemingly difficult and risky process.

 

Does anyone one know what needs to be done to fix it so tat SMB shared folder/files become accesable again?

Otherwise the Media Player for me is simply unuseable.

 

I have made a request to firecore support to ask the same thing but seeing as there is limited forum topics on the subject I am thinking I am simply doing something wrong.

If you know what I need to do I would love to hear about it.

It seems that it is also a problem with XBMC as well, not that I use that klunky peice of crap.

 

I have spent a good 2-3 hours trying different things but with the lack of info on the web it is becoming increasingly difficult to know what to try and what is relevent to my problem.

 

If I get a fix for this I will be sure to post it here to help other with this issue.

 

Cheers

 

Simon

I find myself in exactly the same situation as simond.9355, I wish I had of seen this before deciding to upgrade to Lion.

I only had my ATV2 working gloriously for a week before it has ground to a bit of a halt where my external media drives are concerned.

Many thanks to anyone who knows of a fix for this that dosent involve going the macports / Xcode route.

Cheers Val

I am having the same problem.

I read that you need to upgrade SMB to SMB3 then it works.  I am about to do it now.  Here is the instructions http://www.johnlarge.co.uk/2011/07/19/osx-lion-samba-smb-shares-broken-xbmc-not-working/

 

On a second note, which is better to use?  SMB or AFP or Upnp?  or is afp and upnp the same thing?

 

 

The link points to the work around that I am just not nerdie enough to attempt.

good luck.

Same problem here… SMB and APF sharing problems… and even worse if you have (like me) an external USB HD attached.

Lion has a complete overhaul of SMB (we’ve actually been anticipating it pretty heavily at my office to fix a bunch of issues we have) so this is likely something that’s going to have to have a serious workaround.

If you’re using Media Player you can use AFP instead of SMB. Details on enabling AFP on your Mac (if not already enabled) can be found here. http://forum.firecore.com/topic/5020#comment-19640

Thaks James, I have tried all combinations of the ticks you say in your post but  no succsess.

The fact that suggest me a possible bug in Media Player is: Go to Settings (under Media Player 0.6) > Manage Shares > AFP >Select my iMac and… everything showed in completely diferent to the shared folders in sharing settings on the mac. Fake or corrupt folders.

 

Anyway I can select the any folder execpt those that are in the attached HDD. (Unfortunately are the ones that I want).

 

Does the attached disk have a MacOS type filing system? I have seen reports that PC compatible systems such as NTFS or FAT32 do not get shared out correctly. Apparently this is Lion issue!

Which folders are you seeing? Has a username/password been entered for the share? If not, the AppleTV will attempt to connect as a guest which may prevent some folders/drives from being visible.

Also, as itimpi mentioned it could be related to a drive format issue.

After upgrading to OS X Lion I was’nt also able to connect to AFP-shares. But this problem could be solved at least.

Delete the Home-Folder in the sharing-preferences in Lion and it works fine. I don’t really know whats the differenz is, but a mac-developer gave me an hint, that the AFP-Server in Lion crashes, if there is an home-folder mounted in the sharing preferences. 

I had the same problem, have Lion and cannot contact SMB shares at all, for hours bizzy! Then I unchecked the SMB lock in shared Maps and click on the AFP,

after a few moments the folders and files shows up on my screen and Media player was working, it is not so sophisticated as XBMC but it is working.

I am happy that Media player is working!

Lion mounts the home-folder automatically if you connect to a sharing-partner via AFP with the Username and PW - additionally the Macintosh HD and all ext.HDs if the User is an Admin-account.

 

Exactly thats also my problem.

I tried everything you said:

  • Format in Mac OS system
  • Uncheck everything but AFP (taking into account the problem above)
  • user/psw in Media Player AFP settings
  • Unlocking  the lock in sharing settings
  • Remove all shared folders.

 

And… amazingly … it works. No fake/corrupt folders, just my username folder, root mac folder and my USB HDD disk. … extrange things because if no folders are shared, how is possible that Media Player found somethig?

 

Anyway it works,…

 

Thank you everybody for your time