Mac OSX Lion share issue - Cannot find SMB or AFP Shares

Hello All,

I am suffering a problem where I can no longer find the SMB shares on my Apple TV 2 now that I have installed Mac OSX Lion.

I have seen on other posts that there is a work around using macports and Xcode.

This is a very long winded and seemingly difficult and risky process.

 

Does anyone one know what needs to be done to fix it so tat SMB shared folder/files become accessible again?

Otherwise the Media Player for me is simply unusable.

 

I have made a request to firecore support to ask the same thing but seeing as there is limited forum topics on the subject I am thinking I am simply doing something wrong.

If you know what I need to do I would love to hear about it.

It seems that it is also a problem with XBMC as well, not that I use that clunky piece of crap.

 

I have spent a good 2-3 hours trying different things but with the lack of info on the web it is becoming increasingly difficult to know what to try and what is relevant to my problem.

 

If I get a fix for this I will be sure to post it here to help other with this issue.

 

Cheers

 

Simon

The simplest option would be to use AFP instead of SMB when streaming from a Mac.

Is there a reason you prefer SMB?

I cannot seem to get my external HDD’s to share via AFP, it only shows up when shared via SMB, wait, they “did” only show up when I shared them in the SMB format, since the upgrade to MAC OSX Lion, they do not show up at all.

If you can tell me how to see them when shareing in AFP I would be very happy to overlook this problem, and I am sure the others out there with the same problem would be happy to find out how to get AFP shares on there MAC OS to show up on the ATV2.

I am sure James (the Wise) will be able to point me in the right direction.

Listening with hope.

 

Simon

Here’s how to enable AFP sharing on your Mac.

  1. Select ‘Sharing’ from the System Preferences pane.

  2. Ensure the ‘File Sharing’ option is checked.

[[wysiwyg_imageupload:73:]]

  1. Click the Options button and ensure the ‘Share files and folders using AFP’ option is checked.

[[wysiwyg_imageupload:74:]]

  1. Your Mac should now be automatically detected as an available AFP share on the AppleTV.

No Luck, nothing shows up except the sever name, it shows no files or folders to look through.

thanks - worked for me.

Well, I’m glad this let someone access AFP shares.  I can no longer after upgrading to Lion tho it has worked flawlessly for years in earlier OS Xs. 

I tried to access the AFP shares from a Mac Book Pro and couldn't get to them either, which told me I had at least some problem with Lion. On the Apple forums, I found many reports of Lion problems with AFP shares.  The advice was to go to the Sharing pref (as above), click options and click off AFP, leaving on SMB (the reverse of the above). This did let the Mac Book Pro see and access the files on the Mac Pro under Lion.  The explanation was that Apple removed some part of AFP that was judged to be less secure.

I changed my Mount via Nito to be SMB. However, that still doesn't work and I still get an error message from Nito TV when trying to mount the shares, either as SMB or AFP. So I think there is something that ATVFlash has to fix.

I was using Plex to play avi’s then stopped working - still can’t figure it out. I am using Lion.  Then i saw video using new media player.  On my main screen under media i have only 2 choice files and settings.  This is not what Firecore video shows it should look like.  Anyways I managed to get it to work.  Initially i could only get the “/” to show on the screen nothing else.  Then i used my log in name and password for my MBP and went into settings - sharing - made sure file sharing was selected (which it was) then noticed i did not have the proper “shared folders” selected which had my avi’s in them.  After doing that - it worked.  Still would prefer Plex - but gave up.  I am hoping Firecore can help fix how the Main Menu looks so it looks like theirs but in the mean time it works (most of the time )  ;)

My Files and Settings are all that show up by default on the main Media Player menu. However if you go into My Files, select a share and then navigate to a folder (e.g. Films) and at that point hold down the OK button up will pop a menu allowing you to set that as a Favorite.  Anything you set as a favorite will appear on the main Media Player menu for fast navigation to that point.   Favorites will also appear under My Files, and from that point you can edit/rrename/remove existing favorites by selecting one and holding down the OK button to bring up a menu.

Worked - I feel dumb. That was easy. Now, how r u guys going to raise the the debt ceiling? Being from Canada I just sit in stands and watch my world shake. Too bad you can’t just push and hold the select button and the problem goes away.

Hello again,

I am still having no joy with being able to access the files or even the directory of the external HDD’s I have attached to and shared through(as above) via AFP or SMB(I know SMB is gone now)

Can anyone help me with a work around or advise if Firecore is going to match the share protocol that OSX Lion is now useing.

I am really peeved as I cannot use the Media player at all and I really prefer it over all the rest out there.

Looking forward to any responces I get.

 

Cheers

 

Simon

If you’re attempting to stream from an external drive you will want to make sure the drive is listed in the ‘Shared Folders’ section of Lion’s File Sharing settings.

 

James, I’ve been streaming using AFP from external drive hooked to a Mac for several years (so I’m not new at this).  When I update that Mac to Lion, I get an AFP_MOUNT error.  As I mentioned in my post, I tried to share via SMB, following advice on Apple’s Forum about AFP shares and security changes.  The SMB share didn’t work either.

OSX v 10.4.11 (Combo Update) was used when ATVFlash was first installed on my Apple TV.  Has anyone confirmed that a Mac with OS X 10.4.11 OS can actually connect to an AFP volume shared under Lion?  

Are you using a black or silver AppleTV?

 

The original silver model.

Ok, this the 2nd gen (black) AppleTV section.

Silver AppleTV questions can be posted here.

 

Hey James,

I have done exactly that already and can only browse through my files on the main HD on my Mac, it will simply not show the 2 external HDD’s that I have connected to the Mac and that have been shared under the File sharing list in the Settings pane.

I have tried sharing the HDD’s as a whole and even tried just sharing 1 folder or all the folders separately in the shared files section of the Setting pane. I have had no luck what so ever, even with only AFP shares ticked, with both AFP and SMB check, with only SMB checked, nothing is working.

One thing to note also is that even when I unchecked SMB shares it keeps the tick in the box next to my user name in the box below the SMB/AFP share tick boxes when you click the Options button under file sharing setting pane, even after I enter the password to remove the tick.

I just ant to be able to share the HDD’s as you can imagine, and not being able to is becoming very very frustrating.

If there is any other way to make this happen, any at all, I would be very happy to find out what it is, as I am sure allot of Mac OSX Lion user would too.

Cheers again,

 

Simon

Not sure if my problem was the same as yours but I was also unable to see my external USB drives when sharing via AFP on my mac (this applied to Snow Leopard and Lion).  I previously used to use SMB which worked fine but switched to AFP when I upgraded to Lion.

 

Anyway, I solved the problem by finding out that shared USB drives under AFP MUST be formatted to the Mac OS system.  The drives will not be visible even though you have shared them through AFP if they are formatted as FAT or NTFS. 

The problem is that the Mac will allow you to share FAT/NTFS formatted external drives under AFP and gives you no warnings that they will not actually be shared so you are faced with the frustrating situation of not being able to see the shares on the Apple TV yet everything SEEMS to be working.

It was a real pain because I had to take all the media off the USB drive, format it to Mac OS and then copy the media back on.  It works fine now though (until I need to plug the external drive into a PC of course!)

Hope this helps

Thanks for your info rndrummond, I was suspecting that AFP sharing problems were related with format system.

I was suffering same frustracting days as Simon, since my media are in a USB external drive (in NTFS for potencial PC transfers). I’m going to format another drive in order to test, and I`ll post conclusions.

 

 

 

 

No success with an 4gb USB prendrive formatted at MAC OS Plus

 

Same problems… In fact I notice that allways get fake/corrupt shared folders, when I try to map the folder that I want, so that seems an aTVflash AFP bug