Lots of Apple TV / Infuse / Jellyfin problems at 7.4.2

I am seeing a huge number of issues with Infuse 7.4.2 on an Apple TV 4K.
I’m currently running:
Apple TV 4K (15.5.1) + Infuse (7.4.2)
Jellyfin (10.8.1 + Infuse Plugin 1.4.2.0) on a Synology NAS

I primarily use Jellyfin for recording TV onto a NAS, and then use Infuse on an Apple TV to play those programs. As such, new files are being added to the underlying libraries & folders throughout the day. These recordings are then being watched and usually deleted immediately (but occasionally I will retain them).
Everything appears to have been working fine until the latest Infuse release.

I am seeing the following problems:

Watched flag not working:

  • Files are not being marked as Watched after they’ve been viewed.
  • Manually using the “Mark as Watched” option isn’t working either - the files remain as unwatched.
  • Jellyfin shows the file as “being watched” (Infuse is correctly causing Jellyfin’s progress bar to be updated) and when finished, Jellyfin is marking the file as having been watched. But Infuse continues to show the file as Unwatched.

Under “Recently Added TV Shows”:

  • Nothing is changing under the “Recently Added TV Shows” heading.
  • Newly recorded episodes for existing folders do not appear. However, new episodes can be found when navigating via “Favourites”.
  • New Folders (for brand new Series) do not appear at all. However, these new folders can be found when navigating via “Favourites”, but are not alphabetically in the right place. Infuse appears to be listing new Folders between “D” & “E” regardless of what letter the folder actually begins with.
  • Deleting a file deletes it from the NAS & Jellyfin, but the file still shows in Infuse.
  • Folders for Shows that have been completely removed from the NAS & Jellyfin are still showing in Infuse.

Movies:

  • New movies are not being added to “Recently Added Films”.
  • New movies are not being added correctly to an alphabetical list of Movies when viewed via Favourites - they are being added to the end of the list.

Performing a manual “Scan For Changes” results in no new content being added (or old content being removed).
The Libraries & Files appear to be scanned if you exit, close and restart the App, but no new content is added (or removed).
Infuse continues to report the same number of Movies, TV Shows and Other regardless of what changes have actually occurred.

I have deleted the Jellyfin Share, then exited, closed and restarted the App, and re-added the Share.
The libraries & files are scanned, but the resulting content is exactly the same as before the Share was deleted.
Restarting the Apple TV after closing the App produces the same results.

In order to get up-to-date content added to Infuse, the App has to be deleted.

I have Infuse installed on an iPad & Mac (also running 7.4.2) using the same Jellyfin share and do not see any of these problems. Libraries are being updated, new content added, old content deleted and files are being marked as Watched as expected.

3 posts were split to a new topic: Playback issues on Mac Pro 5,1

Are you using multiple users on your Jellyfin server? If so, can you check to confirm you are logged in with the same user in Infuse and the web UI?

You might try removing and relinking Infuse from Jellyfin, to see if that helps.

I only have one user on my Jellyfin server. I use that user for accessing the Jellyfin app & on all Infuse apps (Apple TV, ipad & mac).

On the Apple TV I have tried pretty much everything I can think of, including resetting the Apple TV back to factory settings.
After installing Infuse and setting up the Jellyfin as a share, everything works fine until …
and it’s that “until” that I’m trying to figure out.
When that “until” occurs, all the problems that I outline in my first post start happening.

I think there are a number of different scenarios that trigger the problem.
One that I’m fairly certain of is when Infuse crashes - from that point forward the problems start happening. The only solution I’ve found so far it to restart the Apple TV - nothing else seems to get things working again.

Two other issues that I’ve noticed occurring once the problem has been triggered:

  • Infuse downloads less than 500Mb of a file during playback (usually I would expect see it download the entire file)
  • Any changes made to Infuse’s settings are actioned immediately, but once the app is restarted the settings revert back to their previous values.

All the problems I’m seeing seem to be memory related. Infuse appears to be unable to update any of its own memory.

I had to reset my Apple TV 4 times last night & 3 times this morning because of these problems.
Two of these resets were power off/power on resets because Infuse caused the entire box to hang.
I have other apps installed, but have only used Infuse since the Factory Reset.

This isn’t all down to using Infuse to predominantly watch TS files (recorded from an HDHomeRun tuner), is it?
I know Infuse has never been good with TS files. Unlike VLC & MrMC, it struggles with files containing mixed aspect ratios & mixed sound formats (2.0 & 5.1 in the same file). I get the impression that Infuse reads the header and expects the file to be in that format throughout, which, when recorded off broadcast TV, it is often not going to be. Presumably VLC & MrMC get their info from somewhere within the stream itself.

Maybe it’s down to the way I watch these files. Typically I will start playing a file and then immediately attempt to scan past adverts and then press Play about 3 mins into the file.
In happier times, Infuse would continue to play the file without a problem, but these days you can see that it is struggling.

Tried to watch a 14Gb film last night. After 4 crashes and 4 reboots, and only 7 minutes into the film, I gave up on Infuse. Ended up watching the film using MrMC - and it played it without any problems.

If this happens again, can you send in a report from your device (and post the code here)?

The following issues were occurring:

  • Played flags not being updated.
  • Buffering restricted in size.
  • Deleted items not being deleted (in Infuse only).
  • Scan For Changes not causing Recently Added TV to be updated.
  • In settings, I set “Details View” from Modern to Classic (see later).

Tried to Submit Diagnostics - got error “Upload failed”.
Internet connection ok because other apps were able to stream.

Closed & Exited app.
Restarted App.
All problems above still occurring.
Details View had been reset (not by me) back to Modern.

Tried to Submit Diagnostics - got error “Upload failed”.
Internet connection ok because other apps were able to stream.

Restarted Apple TV.
Entered Infuse.
Everything now working, libraries updated.
Tried to Submit Diagnostics - this time worked (Code: 5VPAV) - but I assume that these will be useless because everything is (temporarily) working.

… and it’s gone wrong again, and the diagnostic upload fails

It’s interesting the log uploads fail when the issues are present. These logs are uploaded directly to an S3 bucket on AWS (the same server that power a large portion of the public internet) so if the Apple TV is unable to connect to this, it may indicate a deeper network related issue - either with the local network or even your ISP.

Can you provide a bit more info on your network setup?

Are you using any kind of VPN software on your computer/router etc…?

Are you using any custom DNS servers?

I don’t really know how to answer your questions - I’m not that technically minded.
I haven’t knowingly changed anything networky in years.
I use a VPN on my mac, but I don’t see how that comes into play here. The Apple TV only communicates with my Synology NAS, neither of which have VPN.
I don’t knowingly have any custom DNS servers (whatever that means).

All I can compare what I’m seeing is that it’s like when a program on your pc goes out of control and starts looping and eating up all the cpu so that eventually your pc hangs and the only option left is to switch the power off.
That’s what I’m seeing with Infuse on an Apple TV - it looks like it’s eating up resources. In extreme cases, if Infuse doesn’t crash first, then the box just hangs completely and I have to pull the plug out.
Even when Infuse is not updating its own memory on the Apple TV (my description), its still communicating with the NAS, Jellyfin & Trakt. And the Apple TV can still stream video from apps like YouTube & BBC iPlayer.

The problems I am seeing all appear to have started with 7.4.2 when files began to be listed in the wrong order.