Lost whole library


it happened to me two weeks ago, like almost everyone else. One day whole my library just disappeared. I followed this thread: Lost all Favorites, Up-Next, etc. But nothing worked for me.

I tried steps in “What to do if you are affected” but absolutely nothing changed. I switched off iCould Sharing, removed the application from apple TV etc. Nothing works for me. I still have empty welcome screen.

In “Shares” I can see my home Synology NAS and I can connect without a problem. I can even add my video folder to favourites and folder will appear on the first screen. But that’s all. No collections, no sections nothing… just my one folder from NAS.

So I was waiting for some updates but right now it looks like that problem is solved and I’m the last one with the issue…

Can you help me with that?


First, how are you connected to the one share you have? DLNA/UPnP won’t work with the Library function you have to use one of the other modes like SMB.

Second, make sure the Library function is turned on.
Settings > Library > Show Library (Must be checked)

You should now have the “Library” favorite on the home screen. Now all you need to do is to add what you want for lists and other favorites.

Now wait till the Library completes it’s scan and then do the following.

If you want the Top Rated Movies either as a favorite or as a list you go:
Library > Movies > By Rating > Long press on “Top 30” and select if you want to “Add To Favorites” or “Add To Lists”

Do the same for any other category in either TV shows or movies you want.

Hope this helps!

1 Like

Thank you for a quick response! So the main reason was that when I reconnected server two week ago I used UPnP instead of SMB! Thank you so much ? It helps! I would never guess that ?

Thanks again,