Lost connection to SMB server after upgrade to beta 7

After upgrading to beta 7, i can not access my SMB server from the Apple TV. Internet connection via WIFI works fine, trying to access the SMB server throws the following error message:

Could not open dir [smb://name_of_smb_server/]. Reason: connection refused (61)

Apple tv software: 4.2.2 (2203)

ATV flash black beta 6

Breaked with Seasonpass 0.7.6 (73)

Maintenance Version 0.7-28

Mediaplayer Version 0.8-144748

Firecore Serial DCYFJ3SWDDR5 (diagnostic info submitted)

Nas: Netgear ReadyNas Duo

 

Please advise.

Cheers,

B.

 

Can you try the test connection option found under the Manage Shares menu?

Have you opened a support ticket yet?

I was able to resolve this issue by doing the following two steps:

  1. Updating my Netgear ReadyNAS to the latest firmware version (4.2.19 released on 08/30/11).

  2. Changing the Windows workgroup in the XMBC settings from the default workgroup to my workgroup (forwhatever reasons this setting was reset to default).

Anyway, it works now. Thanks for your fast reply!

Cheers B.

PS.: The error message in my initial post was issued when trying to test the share in the mediaplayer settings.

I’m having the same problem connecting to my Netgear Stora NAS after upgrading to Beta7. AppleTV and Stora are both on the latest firmware, and the Workgroup trick did nothing for me.

Neither SMB nor AFP is working.

Get the following error message when trying to connect over SMB:

An error ocurred. Could not open dir (smb://STORA). Reason: Operation not permitted (1)

Get the following error message when trying to connect over AFP:

AFP connection failed: unreachable network or incorrect login/password.

I’ve filed a bug report with the relevant details.

+1

Apple Time Capsule 2GB

I’ve got this problem too. Did’nt have the issue with previous version. I’m using 2 x CH3SNAS and 1x CH3HNAS.

There is no issue with XBMC.

Similar problem over here

Has anyone been able to resolve this yet? I have the same problem but with a D-Link NAS box. 

Everything worked just dandy before updating to Beta 7 this morning.  

Changing workgroup settings has no effect.

Suggestions always welcome.

…desh