Loss of ALL Network Options (Ethernet and WiFi)

I had previously jailbroken my Apple TV 2G with PwnageTool on 4.0 software.  Everything worked great, and I had Plex up and running.  Since it appears that the most recent version of Plex requires 4.1.1, I finally decided to upgrade.

I upgraded to 4.1.1 with Seas0nPass.  Everything completed successfully, but when i tether booted the Apple TV, I could not get any WiFi or Ethernet connection.  Nothing is listed in the available network list, and if I put in my SSID, I get an error.  If I use ethernet, it doesn't sense the connection even though the cable is solid (and the lights are on).  

I restored back to official 4.1.1 firmware (8C154) via iTunes, booted up the Apple TV and confirmed that everything was working the way it should (minus the jailbreak of course).  

I then re-jailbroke with Seas0nPass, and again, I have no network - either WiFi or Ethernet. 


Version 0.6.6 fixes an issue where the AppleTV would forget a wireless network, but the issue you're describing seems to be different.

To help troubleshoot this please send in the log file locate at: ~/Library/Logs/SP_Debug.log 

So I restored/jailbroke with Seas0nPass for the 4th time, and everything seems to be working now.  I honestly do not think I did anything different from the prior 3 attempts.  But my Ethernet connectivity is back! 

My Apple TV rebooted when I was trying to pair/unpair my new Harmony remote.  Now, I've lost network connectivity again.  I tried 2 tethered reboots with the same results. 

Does this mean that I have to restore to a fresh jailbreak again?  Will I have to do this every time I need to reboot?  If so, this is more than a "tethered boot".