Long wait time after 5.8

Because the slow down seems to be caused by this new “feature” of constantly updating in the background.

Thanks, but I tried logging out of both Trakt and iCloud. Didn’t notice any difference.

I remembered that I also did change to Legacy SMB. Haven’t changed it back since it works like pre 5.8 for now. Desperate measures :stuck_out_tongue:

A few minors changes that could help in some cases are available in today’s 5.8.2 update.

Some more general and far reaching changes that should provide a quicker and smoother experience for all will be available in 5.8.4, which isn’t too far off.

I updated to the latest TvOS and Infuse 5.8.2.
My previous problem is solved. I changed back from SMB legacy to Auto and logged into Trakt account again. Access to the shares are running smooth again. Thanks for the update.

Awesome! :smiley:

Thanks for following up.

But first 5.8.3 ? :wink:

5.8.3 has already been submitted to Apple, and includes support for iPhone XS Max and iPhone XR. :wink:

I’m not convinced the update has fixed my issue, but I will I need to spend some more time testing.

To explain, when I load Infuse and go to the main screen, it’s as though my Apple remote becomes unresponsive. If I wait (in my attempt this morning, about 10 seconds) then I can then start moving around and selecting favourites, but not before then. Going into these folders produces a grey screen with a spinning icon on occasion, and this spinning icon can take up to 30 seconds before going away and displaying the folders on the NAS.

Note - On 5.8.2 and tvOS 12 that both came out this morning for me here in NZ.

I’ll get back to you in 24 hours after proper usage.

Thanks, Phil

I just updated to tvOS 12 and Infuse 5.8.2 and reconnected my Trakt account, but it still produces about 90 seconds of unresponsiveness shortly after starting up Infuse. I’ve submitted a ticket under the code TTXER. During the 90 seconds while it is unresponsive, Infuse remembers my remote clicks. For example, if I press MENU twice during this period, a minute later, it will go up 2 directories, so it is seeing my input, just not able to respond to it.

Since it looks like you’re part of the beta, can you try installing 5.8.4.

Please share any feedback related to 5.8.4 in the beta thread. Thanks! :slight_smile:

:frowning: Dunno what happened. I’m back to the original problem.
Oh well… I probably have to wait for the 5.8.4 - Will log out of Trakt until then


Let me know if you want to try the 5.8.4 beta.

Hmm, curious. OK here’s some notes from me (that may or my not help)….

Yesterday (after installing tvOS 12 and Infuse 5.8.2) I posted here that I wasn’t convinced that the issue was fixed. Part of my problem is that the issue seems mostly unresolved, but there are moments where it seems resolved (perhaps this is what you experienced vibaek?)…for example, last night I didn’t seem to have many issues, and this morning, Infuse loaded smoothly.

But here’s something else I noticed this morning. Yesterday I decided to clear all the metadata on the off chance that this had something do do with it. Infuse then went through and started pulling all the appropriate metadata and thumbnails again…until everything was looking great.

This morning I launched Infuse and I could move around the home screen (which is usually something I can’t do immediately due to the issue). I noticed the spinning icon (top right) and decided to go and investigate.

I went to Settings - Library…and then sat there to see what was happening. One of the things that surprised me was (at the bottom of the screen) “Fetching thumbnails for Media Server 0 of 5655”…and then it started gradually pulling in thumbnails for each of the files. But what I don’t get, was that it had done all that yesterday? It looked like it was starting all over again? Could this be part of the issue?

Just a thought.


No idea why I have been saying tvOS 5 and not 12…I’ve corrected my posts

It’s definitely worth a try.
Philip Roy’s thumbnail observation in the library settings is also interesting.
I haven’t noticed that myself. But logging out of Trakt again seemed to smooth out things for me.
Is the Trakt account link something addressed in the 5.8.4?

Just to update, since the 5.8.2 update I’m still having this issue and it repeatable. I’ve sent in the diagnostics and submitted a trouble ticket.

I apologize for muddying the original posters issue but wanted to follow up in case others find this same issue. Mine may be a bit different since I don’t use Trakt.

Quick update.

We’re working to pin down a specific issue that can appear in some cases, and are hoping to get some more info from a few people who may be seeing this.

If when first opening Infuse you find it is unresponsive for a few seconds, and are willing to install a special build via TestFlight that will allow us to collect more info, please let me know and I can get you set up.


A number of improvements for Trakt are available in the 5.8.4 update which was just released.

We’re also working on a few more general improvements for the 5.8.5 update.

Faster is always better. :wink:

Hi there,

I wanted to take a couple of days before replying. From what I can see, with the 5.8.4 is a lot faster and resolves the issues I was experiencing…no freezing of the app and the remote is usable all the time :slight_smile:

Cheers, Phil

1 Like

Great! There are a few more minor changes coming in 5.8.5 as well.