Long wait time after 5.8

After upgrading to 5.8 and 5.8.1 it takes ages from starting Infuse until I can see/access my SMB shares from my Qnap Nas.
Before 5.8 everything worked like a charm, but now I cant instant access the direct shares like I used too.
I know some suggested to use the Library instead. 1) I don’t think it is as userfriendly as my direct shares and 2) I don’t think it helps speedwise.
The problem persists on both my ATV4’s. I tried changing to Legacy mode, but no difference. I tried turning iCloud sync on and off… Same-Same.

Am I the only one having this issue? Or is this the issue others have with the metadata?
Both ATV’s have over 50% free space. Therefore it can’t be the “autodelete temp data” that was suggested as the reason in the metadata threads.

Even the wife started commenting on this problem, som as you can see, I’m in a pickle now…

I haven’t noticed any significant change in the startup speed on my system … but everyone’s setups are different.

I would suggest submitting a report from the ATV so that it send the logs to Firecore so they can look to see if they can see anything from the logs which are causing the delays.

1 Like

Since the addition of the fetch button/busy indicator on the home screen I’m seeing an extended wait also. If I launch Infuse and just wait on the home screen it takes several minutes ( (over 10 minutes) or (if at all) ) for it to complete the update. Now if I launch and go directly to the Library settings screen where you can see the status information Infuse completes the scan in under two minutes. I am not clicking on the update button, just going to the screen where I can watch the progress.

This is from a condition where the NAS and computer where files are hosted are both asleep.

I’ve got a bit more testing to do to try and narrow down the issue.


Glad I’m not the only one.
Just to make sure it wasn’t the NAS sleeping, I woke it up, and entered the folder with my phone right before I started Infuse, but that didn’t change the problem. Still had to wait several minutes to enter the share…

I hope you can narrow down the issue, and we hopefully have an update solving the matter in 5.8.2 or 5.8.3

I had to give up on SMB. Even NFS is now slow to load sometimes. It sure was faster som updates ago.

1 Like

My issue isn’t related to protocol, it appears to be involving when Infuse actually initiates it’s update calls. Once it starts it’s fairly quick. I’m guessing that Infuse has modified it’s start up routines and there’s a missed call that gets found when you navigate to the library settings and it kicks off the process.

Okay, did a test tonight.

First I made sure both NAS and Mac that hold shares used by Infuse were asleep.

Next, I launched Infuse and did not click on any icon or button on the home screen, just launched and watched the spinning indicator of the update.

Waited for a full 10 minutes the entire time the wheel kept spinning.

Checked the NAS and Mac and both were still asleep.

I clicked on only the Setting Gear Icon and that action woke both the NAS and Mac and the update was completed in less than a minute from clicking the settings icon.

Seems that Infuse is not sending out the wake command until you click on something like the Settings icon. Is someone has a net sniffer that could watch for the wake call coming from the ATV once Infuse is launched and see if it’s really sending one on launch or is it waiting for additional clicks in app.

I don’t know for sure how long this has been occurring since until the latest version with the spinning wheel on the home screen my routine was to launch Infuse and immediately navigate to the Library settings so I could see the status lines of what was going on. That would have woke the NAS and Mac at that point and why I have been seeing reasonably fast updates prior to the latest update.

OK, here’s my situation.

I don’t use library mode because I get a much more useful start menu with my own favorite folders. When I press a favorite folder, spinning wheel appears (of course). Here is a ranking of which methods work fastest when it comes to getting past the spinning wheel and to the content:

  1. Apple TV 4K wired NFS
  2. iOS NFS
  3. Apple TV 4K wired SMB
  4. iOS SMB

It takes a relatively long time when I start Infuse for the first time in a while, possibly because NAS is in sleep mode. I’m not an expert on these things. Once the folders have been opened and loaded once, I can switch between them and find content fast. Startup time for the individual files are also good.

When I hear someone talk about ten minutes, I have to stress that my problem is much less. It varies from about 15-20 seconds with Apple TV wired NFS to maybe 60 seconds with iOS SMB. So why do I complain? Wife haven’t even commented it yet…

Two reasons:

  1. I am picky and want everything to be as instant as possible.
  2. (Most importantly) it was faster before.

I don’t know why it’s gotten slower, but I hope Infuse 'developers will give priority to looking at it.

My NAS is not asleep. I tested, adding 1 file via my MacBook to my NAS via SMB share. Then I turn on my ATV4, enter Infuse and try to acces one of my SMB shares… the spinning wheel takes up to 5-10 minutes. And it is now every time I boot up my ATV.

I’m used to 30-60 seconds MAX before access to my media content.

I found that about 20 seconds after start up, my Infuse on 2 ATV4 and 1 ATV4K would freeze for about 90 seconds, where I couldn’t interact with the program at all. Logging out from Trakt solved the locking up on start up issue for me, but now of course I can’t use the features of Trakt. This started in version 5.7.* sometime.

If you are seeing any issues like this, we’d love it if you could send in a report (and open a support ticket) so we could look further into what may be going on.

I raised ticket #106698 ??

Logging out of Trakt account made a huge difference for me
Now smb shares are accessed within 6-8 seconds again :sunglasses:

Oh thank god it’s not just me :wink: This has been driving me nuts, but coincided with my ISP giving me a newer modem, so I kept trying to think what I was doing wrong. I kept coming to the forum and not seeing anything either.

I’m getting the same delays with my Western Digital NAS. I often go into a favourite and face another spinning cursor and need to back out of the app completely and start again. It’s massively delayed compared to how speedy it used to be, and has only happened with 5.8.x releases.

Ticket just submitted in #106775

Cheers, Phil

Same here.

I have exactly the same problems.

Same as which? Never waking the servers and starting the scan until navigating away from the home screen or just slower to scan? I guess I muddied the waters when I added my issues instead of starting a new thread.

I hope this gets fixed soon. It is very annoying that everything is slowed down each time you go to the Home screen. What is actually the purpose of having this constant updating running? It worked fine before.

Not quite sure why you did a “sound bite” quote of my post but my issue isn’t that it slows down every time I go to the home screen, it’s that when I launch Infuse and don’t click on any other item it doesn’t appear to send the wake packet to the NAS and computer where shares are stored. Once I click on the “Settings” or a share the wake is sent and it’s as fast as always.

This also seems to be a different issue from the original posters so I didn’t pursue it in this thread. I’m waiting for the 5.8.2 release to see if the issue persists.

Try logging out of Trakt. It worked for me