Local Metadata xml not displaying.

Hi James,

Infuse on ATV4 (with content on Airport disk) is my best multi media player - thank you.

I have my home movies folder set to use local metadata & placed local xml & jpg files as per your support article:

As a test the xml file was pasted unchanged from that article & saved vie textedit.

When I open the file in Infuse the thumbnail is there but zero text.

The file edit menu does show the xml file selected but no metadata appears.

Settings “embedded metadata” is off.

Do you have any suggestions please?



Can you attach a copy of the XML file you are using?

Hi James,

I get this message when trying to attach the file:

The selected file 2001-03-31 Visit Jas.xml cannot be uploaded. Only files with the following extensions are allowed: txt, png, jpg, jpeg.

How can I submit the xml?

Can you try changing the extension from xml to txt?

I’ll see if we can enable xml uploads for the forum in the future.

File attached.

2001-03-31_visit_jas_0.txt (7.27 KB)

Did you use Word to open this file at some point? There is a bunch of extra formatting (see attached) which is likely causing issues with Infuse.

I’d recommend downloading the free version of TextMate (https://macromates.com) for editing XML files like these.

Hi James,
Recall that I copy/pasted the text from your webpage into OSX textedit then saved as xml.
I will try textmate.
Is there any template to follow other than the example file for Shawshank Redemption?
Thanks for your help.

Here’s a direct link to a sample xml file. I’d recommend downloading this by right-clicking and choosing ‘Download Linked File’ (or the equivalent in your browser of choice). Copy/paste can get a little wonky sometimes.


Local metadata now deploying fine - thanks for the support.

Awesome! :smiley: