local cover art in grid view

Maybe I'm completely off here, but as I understood I can get local cover art for my DVD folders (with video_ts content):
Give the image the same name as the DVD folder (I.E. the one you select to start playback in MP). E.G. the following two items are in the same folder.

Inception (DVD folder) and Inception.jpg

 

Unfortunately I can’t get this to work in the grid view. I have for instance Inception.jpg in the same folder as the Inception DVD folder. When I select Inception and MP goes to the detailed movie page, I see the Inception.jpg cover art. So this works as expected.

But: In the grid view itself, Inception shows up as a single “file” where it’s picture is the first frame of the movie, instead of Inception.jpg. So in my case as the movie starts with a copyright warning, the “cover art” is a copyright warning.

Any ideas?

 

BR. Leo

(btw this is a repost as I think I’ve posted it in the wrong thread previously)

Hi, there are know issues in grid view for local cover art, the fix is in the next release!

Works much better in the last ATV Flash update!

One thing though: It appears that the local coverart of the last item of the grid view doesn’t work. The “cover” stays black…

Gray ‘ticket’ images will be shown for files that for whatever reason have no cover art available. Can you provide the name of the file you’re having trouble with? 

You may also try highlighting the file, holding select, and choosing the ‘Reload Metadata’ option to try and locate an image for the file.