Loading & spinner

Hi,

Every time I am opening the Infuse app on ATV, it starts with spinning and loading. Until loading is completed I cannot see my content on the home screen. Also my next up/progress content is at that time not up to date and have to wait until this is updated. Quiet annoying if you want to watch something quickly. In Plex app all content is visible after launching the app. Is there a setting I have to switch off or on? I have turned the metadata setting off but no improvement.

Thanks.

First, what model of ATV? What tvOS and what version number of Infuse?

Id suggest you leave metadata fetching turned on and make sure embedded metadata is turned OFF. Embedded can slow things down since Infuse has to inspect every file.

You should not see any delays on start up once Infuse has completed it initial scan and has built it’s library. If you go to Infuse settings on the library page it should tell you the status on the left side under the graphic. What does that say?

Another thing that may help is to go into the ATV settings to the background updating section and make sure it’s on and that all apps other than Infuse are turned off. That will give Infuse the best chance of doing things in the background.

Are you force quitting Infuse?
Are you unplugging your ATV when not in use?

These are all things that users have found to impact start up speeds for Infuse (and many other apps too.)

Thanks,

I use ATV 4k, with version 15 and latest Infuse version.

I have the embedded metadata off and Infuse is the only app with background uodates in ATV settings.

If I go to setting and than library it is saying at the left 'pulling data from " servername".

I am not forcing Infuse to close or unplugging atv. The only thing I am doing is turning off the ATV as ‘stand by’. I have noticed it is happening when ATV is turned off and to leave ATV on for all day just of Infuse makes not sense…

Why is Infuse trying to get all data everytime? What is the purpose of the cache in this case?

Since the tvOS has had an update in the last few days and not everyone is current on it or the latest updates the version numbers may help. Also, what model of atv 4k, 32 or 64GB?

If you launch Infuse and go directly to the library page is will show the process, it will gather all info needed and download the needed metadata from TMDB. It will also sync with iCloud to look for changes from other devices running Infuse that may change your overall library.

I’d suggest leaving Infuse on the library settings screen and wait till you get the “Last Updated…” message.

How many movies and tv show episodes do you have in your library?

I am on version 15.5 (TvOS) and 32GB. I am not using iCloud.

Infuse version 7.3.10.

At the end it is giving the message updated at…

I have a shared library of >1000 TV shows and >2000 movies.

Im also having the issue where once going to library and running a scan it literally hangs and refuses to let me back out of settings to main menu area

I have the same issue with ATV and Infuse, the problem occurs all the time, every day. I think I have found the bug in infuse. I deactived the “send crash data” to off, and haven’t gotten the error again. You might look into this more Firecore.

I also thought metadata was the problem. I think the problem is that infuse wants to connect and send crash data and because it cannot do this it starts a send loop… or something like that.

I can confirm this fixes the issue. With sharing anonymous data turned off, my library loads instantly.

Having the anonymous ’Share Crash Data’ option enabled shouldn’t be causing any performance issues, but if you are able to replicate this issue (perhaps by re-enabling the option) and then send in a report from the device (posting the 5 digit code here) we can look into what may be going on in this case.

Celebrated too soon, loading still takes a long time, with the sharing option turned off or on.

Report code:

X635Z

I tried this morning also. Inactivating this feature does make it possible again to start videos for me. I still have the loading issue in infuse app, but I get access to the folder with media and I can start media also. The preloading icon still rotates but video at least start. I will try more after work and disable and enable feature again.

Hi james, I will try this later this evening when I get back from work.

When I switch on send crash data again, it starts loading and not playing video.

I say it must have something to do with this.

Y5VQD

Hi I’ve got the same issue where it takes a long time to load a library. Have followed the settings through this forum and still the same.