Linksys e3000 and NAS

Have just upgraded from old d-link wireless router to linksys e3000 and are unable to mount share point (using original share settings from d-link, same ethernet connection). I have tried creating a new point with the same settings, and still no luck.....it keeps coming back with..."mount smbfs could not find mount point/scratch/volumes/public:Socket is not connected", ("public" is the folder path)....the weird thing is that everything IS connected (via ethernet). I can see NAS (WD myworldbook 2tb) on the imac and navigate to it's folders and I can see my atv inside itunes on the imac. I am running the latest linksys FW.  Any ideas or suggestions greatly appreciated. Here is a summary; 

Model name: Linksys E3000  

Model number: E3000  

Serial number: CVQ01KC68722  

Firmware version: 1.0.04 build 6  

Operating system: Mac OS X 10.6.6 

Software version: 1.3.11006.1 

Connection type (WAN): DHCP  

IP address (LAN): 192.168.1.1  

IP address (WAN): 211.28.54.58  

Computer IP address: 192.168.1.136  

 

Cheers, Drew.

All sorted using the classic IT method. The new router also sorted out the stuttering playback issue of DVD TS files I was having with the old router.