Library view - fix incorrect metadata help? latest version

first off, here’s my setup:

apple tv software 5.0.2 (4250)

aTV Flash (black) 2.0

media player v2.0.1-359

 

So i have been using the Shares (My Files / Remote) view exclusively up until this latest media player update (with the new library view).  I had everything setup great with a folder.jpeg image in each show folder, and the same for each Season XX folder nested in each TV Show folder.  So the structure for my My Files / Remote method works great

 

When I try to use the new library feature, it is working great for the most part.  The exception of a few stubborn files:

  • The Newsroom is pulling metadata for an old show, not the 2012 one.  I tried making the folder name "The Newsroom (2012)" but it will not find any cover art data.
  • The show "The River" is retrieving some 80s tv show cover art... Instead of the tv show from 2012.  I click and hold button then choose reload metadata on one of the .avi files.  I pick the correct show and it corrects the metadata for each individual episode in that folder, but when i back out to the Season 1 folder and the main tv show folder "The River" still use the wrong cover art!
  • The TV show 'Louie' is pulling some little kid show cover art.  It should be finding data for Louie C.K.'s show.  again, I click and hold button then choose reload metadata on one of the .avi files.  I pick the correct show and it corrects the metadata for each individual episode in that folder, but when i back out to the Season 1 folder and the main tv show folder is still use the wrong cover art!
  • I am getting a lot of the extra files showing up as their own TV SHOW.. for example, some of the extra content from The Walking Dead (behind the scenes/episode commentary short video files) are showing up as it's own tv show "Inside the Walking Dead" (with no cover art found obviously).. can i somehow exclude these? my solution before was to keep these in a folder called "extras" next to all the "Season XX" folders

 

My biggest question that is stumping me:

  • Under "movies" category i am having a weird issue.  There is a movie titled "LOL" and I have not downloaded that movie.. when i look at the filename it is 'simpsons.1413.divx-lol.avi'.  SO if i go to this tv show file on my shared drive what do i need to do to the file name to get it to NOT show up on the movies view in library?  all the other 21 seasons of the simpsons all appear correctly under TV Shows, this is the 1 file that is showing up in movies for some reason..
  • There is 1 video file that is showing up as a show called "On the Way to a Smile - Episode Denzel: Final Fantasy VII.  i know the filename.. what do i need to change in the filename to correctly identify this show

 

Thanks in advance guys for any light you can shed on these issues…  i’d love to start using the library feature for the search and sorting benefits (genres is awesome!)… but for now i’m still using the old MyFiles/Remote option to select my shared drive