Library update stops at pending or never updates fully

Don’t use infuse every day due to not having shuffle but when I do use it I like it to update my library.

It never really has done this “fast” enough. I feel like I have to let it run overnight with the “chance” that the library will update.

Using latest versions of both infuse and Apple TV iOS.

Have it connected to my Plex library. Plex gets updated almost instantly and takes around 30 seconds to scan for updates.

Have had infuse trying for update for around 30 minutes now and went to “pending status”

Searched and that said it was due to iCloud sync which has always been turned off. So I turned it on and back off.

Then went back to library. No change.

Went into settings and clicked scan for changes.

Now I have been at “in progress” for 23 minutes. This is insane.

Plex updates immediately. 23 minutes in and can’t get just a few days of updates.

What is going on and what can I do to remedy this?

Thank you.

As an update. Did an almost full 0 day update on iOS infuse in just a few minutes.

So there is definitely something going on with apple tvOS or how and where it’s stored or updated.

Don’t forget that Infuse can only update when it’s the active app and your not watching a video. The Plex server has the advantage of being able to run on the server any time and as long as nessasary to update the metadata and have it ready to send to the plex players as soon as they request it.

I don’t think iCloud sync has to be onto update, mine updates fine without it. Mine will show Pending as long as it takes to wake the servers and associated drives then the updates occur.

Had the app running with the spinning wheel for the whole time. No update.

Last time I let it run overnight. Not sure how long it ran before everything just went to sleep and powered off for no activity so maybe 3 hours and still no update.

Then all of a sudden after doing this. It might update to “few days ago”. Never is consistsant. And taking over 30 minutes (might even be hours since it still didn’t update) makes me feel something is wrong or broken.

So in the end.

App was open and left on the library part with the spinning wheel “in progress” with no update.

Any other suggestions?

Am I better off NOT connecting it to a Plex server since it won’t use any of that metadata? And just use the same data location?

That is curious, have you been able to check and see if the server that your files are on is awake and drives spun up when Infuse is trying to update?


See my edit above.

iOS updates fine. Fast enough. Just was grabbing “thumbnails” but everything else updated fairly fast and as fast as I’d expect.

And another thought, how are you connected with the ATV? SMB, FTP etc.

If SMB have you tried changing it to “2” or Legacy?

Just trying to check off things that may affect speed.

ATV is hardwired to my network. So should be faster.

My Plex storage and server are both remote.

So if it works for iOS on my network wireless it should work same or faster for my atv directly Connected.

So I might just “remove” the library share of Plex and reconnect it and see if it updates. Could be some random stupid thing stopping it.

I meant what protocol are you using to connect to your server, Plex only, SMB, FTP etc.

Plex only for 99.999% of the files (remote)
And one SMB (local) share for like 50 videos.

By remote you mean a plex server located at a different location and you’re connecting over the internet? Don’t mean to sound ignorant but want to make sure I understand what your up against.

Yes that is correct.

The smb is local.

Both work fine with iOS.

Both don’t uodate with ATV.

I will try full library restore later today.

AS an update to this post.

I am now 42 days “unupdated”.

Started at 802am, status says “updating” at 806 status says “pending” and now 826 (20 minutes) status still showing as “pending”…

again to reiterate. opened IOs at 822…by 825 ios infuse was fully updated…

ANY help with this?

EDIT: After searching, someone said they had to go into “movies” to get it unstuck

at 829 have now gone into "movies’ and status went back to “in progress” Will update as the hours roll along without the infuse player properly updating.

839 still in “in progress” status

closed Infuse, reopened, Went to Library
Went right back to “in progress”

854 “in progress”…

Should I just delete infuse?

I’m still trying to figure out what’s going on with your set up. How many files are on the shares you’re waiting to update?

It does update, only if I let it run overnight for a few days, it will finally update. And if I try and update the “next” day, which will “add” about 10 files, still takes the same time.

I only say that as a precursor because I do not want you to think that I am doing a FULL library update this time.

With that being said.

500 movies files
and about 6000 TV Files.

Just went into infuse

Movies: 545
TV Episodes: 7621
Other: 67

I have found that if I go into “settings” “library” it gives me a “fetching thumbnail” etc update. And after going there, it will update it on the main page. But if i do NOT go t settings/library, it wont update on main page.

Sorry for the trouble.

One thing you can try is to re-authenticate with Plex using the ‘Connect to Plex’ option in Settings > Shares.

Additionally, the upcoming Infuse 6 release will include a number of improvements in this area which may also help.

Infuse 6 will be available later this month.

I saw the news, my hope it is a mix of some miss configuration, with talking with plex, and I plan to start fresh with version 6…(essentially that was why I had spun up infuse again to see how everything was going)

I also say SHUFFLE finally on the upcoming pending changes. I cannot WAIT, then I can finally probably move completely over to Infuse over plex…not that plex is bad, but yeah!