Library update issues when deleting/moving media from Google Drive

I have been noticing the following with media stored on google drive… I would remove (or move) media folders/files from my initial temp dir to my permanent folder (HD/4K.etc…) and when indexing occurs it still shows both copies and will not remove the copy that no longer exists on google drive… known bug? (I’m on v. 6.3.1-2950)

I tried to replicate this year, but Infuse never showed more than one copy.

Are you seeing more than one copy if you browse your Google Drive folders directly via a favorite?

Hi James… what do you mean directly via a favorite? Within Infuse app or on Google Drive via web browser?
If you mean directly from favorite folders in Infuse then yes I do still see the item that was moved/removed there. (I see one from the previous location and one at the new location)

I just tested something else out with my library… I unchecked my google folder under Settings → Library that has my TV shows. I reran scan for changes and it still shows the same count for “TV Episodes” up top. It’s also still showing up in the main dashboard under “TV Shows” section. I tried multiple times and restarting the app as well. No luck having those 25 TV episodes turn to “0”.

I believe items in Google Drive’s “bin” are still counted. Try deleting items in the bin.

Still no luck after emptying the trash in google drive :frowning:

Here’s some screenshots with an example of what I’m dealing with now. This one TV episode that’s been deleted (with trash emptied) is still showing up even after multiple attempts rescanning for changes over 4 days now. (See 7 attached photos)

Even though the file no longer exists on google drive, I tried to delete it via infuse (enabled file mgmt)… as expected I got an error. (See screenshot)

One thing you may try is this.

  1. Add a new Favorite for the ‘New Downloads’ folder
  2. De-select this in the Infuse > Settings > Library menu

The effect of this would be Infuse will not include videos stored in New Downloads folder in the library, but this folder can still be accessed via the Files tab.

Ok, I can see that being a workaround… I’ll give that a shot for now. Are there plans to fix this for the long term? thanks again

Unfortunately, we haven’t managed to replicate this here. But if the deleted files are being listed in Infuse while browsing via folders, that means Google Drive is still including them in the file list it provides to Infuse. It’s not clear what causes this to happen, but it could possibly be a bug or some other quirk with Google Drive.