Library duplicates


I very much enjoy infuse and was waiting for the iCloud Library with anticipation.
It works well but I have a question. Few of my shows created duplicate episodes after the update to 6.

My setup is this:
I have NAS with two IP addresses. One for local LAN and the other for external access. I use the internal on my tvOS and the external on my iPhone.
This creates two shares in the library. On each device I only check the one I want to index and this worked on version 5 without a problem.
I have to mention that after the update I had all my shares checked on all devices and that created duplicates of everything. Upon unchecking to correct this only these few shows stayed duplicate and even a metadata removal and reindexing didn’t help.

What I tried so far:

  1. Take the folder from the share, reindex library, put it back and reindex again but after a while the duplicates are back.
  2. Removed the other shares from tvOS and left only one, removed metadata and did another reindex. So far it looks good but I would like to use the other external share on my phone too.

This is longer then I wanted, sorry.

Welcome to the forum, and sorry to hear you are having trouble.

When viewing these duplicates, can you use the edit option to confirm the filenames you are actually seeing? This can be helpful in some cases to help pinpoint the actual videos Infuse is picking up.

Hello James,

I tried your suggestion and the filenames were exactly the same. I also searched shared folder top to bottom for that filename but only one file came up.
I’m now using only the local share and thats keeping the duplicates away but I can try to simulate the issue again by setting up the external path to the share on the iphone.

I am having the same issue with a Synology NAS. Anytime I add new content it is correctly indexed by Infuse but there are duplicates of every episode. This has only started happening recently.

There are only single files and I only have one library share (SMB) selected.

I’m using infuse pro 6.3.5 (3026).

I have cleared the metadata, changed shares, scanned for changes and deleted and reinstalled all with no effect.

Disappointingly it displays correctly on the very clunky DS Video app

Yup, exact same problem here and I’ve tried all the same things. It’s very frustrating.

Welcome to the forum!

When you post on a thread that’s over a year and a half old there’s a good chance that the problem your having could be caused by different issues. Versions of both the OS and Infuse have changed and many issues from this far back have been addressed over the months or years.

It would help if you would restate what the exact problem is you’re experiencing and post what device or devices you’re seeing the problem on, what is the OS number on them, and what version of Infuse you’re running. Also what are you using for a server and how you’re connecting to them (LAN and/or WAN). :wink:

Hello Everyone,
the same problem appeared to me recently after I changed NAS. My previous NAS was working flawlessly. I tried everything from restoring my Apple TV, removing accounts, etc. The solution that worked for me was quite simple once I found the reason for the duplicates. On the new NAS I configured snapshots which is creating small “file/folder like” item in each folder that’s being backed up this way. Infuse indexing is reading these snapshots and what’s inside them what was causing at least in my case multiple versions. So what I did - except normally selected favorite folders like Movies, TV Shows I also picked and selected as favorites #snapshot folder contained in each of the aforementioned folders. After doing this I went to library and unselected those #snapshots in the library settings (but not removed them, once you remove them, the problem will return). This has immediately solved my problem and now infuse works perfectly as before with just the single versions of each file. Hope this helps to everyone who’s been struggling with this as myself.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.