Library doubled with local and remote versions of episodes

I’ve been using Infuse on iPhone/iPad/ATV for years locally, however I’ve recently tried to set it up for streaming remotely from my Synology NAS and was successful in adding the library through WebDAV. I’m trying to set up my devices such that iPhone/iPad use the remote shared version of the library, while my ATV uses the local share version for faster streaming locally. To do this, I added both version of the same shares (local and remote) but only star the appropriate source on each device.

However, since I’ve done that, my TV shows episodes appear doubled when opening a show through the Watching, Recently Added, or Unwatched lists; when I open a show through TV shows, it shows only the episode from the share i want on each device appropriately. This doesn’t seem to be a problem with my movies which are set up the same way.

Is this a bug where the shows in those Home Screen lists “remember” the other share’s version or am I missing something in how I could set this up?

This is going to happen when you have two different sources. The best option is to use a single WebDAV source and ensure your router has enabled/supports Nat pinning so that requests to the local media are routed internally instead of tromboning out and back in through the WAN interface. Optionally you can set a static DNS entry for the host (I hope you are accessing externally via a host name and not direct IP) to have it point to a local IP when you are on your local network.

Hey, thanks so much for replying so quickly!
Do you have any more info on how to do either of those options?
I set a DDNS to reach the server with port forwarding for WebDAV, so no direct IP numbers. In Infuse, I set up the share with WebDAV and used my DDNS address. What would I need to do/change to make sure that when I stream using this share while I’m on my home wifi it will stream locally?

It depends on your router. Give it a try/do a speed test and compare it to going to a direct local IP. If the numbers are the same then your router does NAT pinning properly. If it doesn’t you might be able to turn it on(depends on the router). If your router allows for manual entries in DNS you can create a host entry such as > my.dns (or what ever the local IP is).

I’ve attached a photo of what the NAT option looks like on my router. It might also be called Nat loop back or reflection.

Definitely different speeds for the same file on the local vs remote shares while on my home network:

Unfortunately, I don’t think my router supports hair pinning, just static NAT:

However, I do have an option for manual DNS entry but it just lists my NAS and its local IP address:

Do I add something else here?

There’s a tab for routing in the settings, would this be useful in any way?

Thanks again for your help, I’m quite new to the networking side of tech.

Are you able to type in a manual dns entry and select your NAS as the IP? You’d want to type in your dynamic dns name as the host name.

I don’t know what you have for devices (or even a NAS) but if you wanted more control over your DNS and some added functionality you could install pihole on a separate computer or a docker container on your NAS and move DNS and dhcp over to that. You also gain the added benefit of whole home ad blocking.

I tried adding the NAS with the DDNS name and my local address to the NAS but it didn’t change the speeds or anything. My NAS is a Synology DS220+ which I have Docker containers running on for different services, but I wouldn’t know the first thing in move the DNS off from my router to it… My router is one that was provided by my ISP, I guess I could look into getting one with NAT pinning. Alternatively, I guess I could make the entire library go through Plex and add my entire library/share in infuse that way, but I thought that might be more resource intensive?

Plex might be your easiest route. You can test to see if your static dns entry is working by doing a NS lookup while connected to your local network. An ba lookup of your dynamic dns name should send back the IP of your NAS vs your wan IP.