Legacy Cache. Remote mounted plaex shares on NAS

To give a bit of idea for the following, my setup is a Synology NAS running Plex with 9 Remote mounts to 2 old Buffalo NAS with a huge chunk of my media collection. Then it has 2 Internal shares with lots of media on it too.

So yesterday I added a plex server to infuse on our Apple tvs so we could get more control of the Metadata. But for some reason infuse keept timing out when playing a movie from the Remote mounted shares and I was thinking at first it was probably some kind of bottleneck that made remote mounts unusable for what I wanted. The 2 internal shares worked fine in plex via Infuse.

Today i was playing around a bit more and I turned Cache into Legacy…and low and behold all of a sudden I could play from the remote mounts via plex on infuse.

Im wondering why this is though? I read its something to do with disk cache?. But which disk? On the apple tv?
Also why only the remote mounts? because it takes longer?
Will SSD cache in the synology do anything to help?
Do i lose anything from legacy cache? :slight_smile:

I hope someone can give me a bit of clarification :slight_smile: but for now it seems to work great :slight_smile:

Thank you all in advance :slight_smile:


With the Streaming Cache set to auto, Infuse will work to buffer more of the video and store it in a stable disk cache. When using Legacy, only a small portion will be buffered.

If the Auto option is working for local shares but not remote shares, this may indicate some sort of throttling issue on the ISP or server level.

Thank you so much for your answer.

Since I wrote the post yesterday it seems i figured out a Solution to my own problem :slight_smile:

On my Synology I have been using CIFS mounts because when i tried to use NFS mounts it only showed a few of the files on the shares i mounted. I tried something called “kernel mode” on my two old NAS boxes and now all my NFS shares works perfectly and everything is so much faster and smoother when connecting to the Plex server from Infuse even with Auto :slight_smile:

Again thank your for using time trying to help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.