Last FM Not Working

Gents

Accidentally posted this in the second gen forum after searching the error I have with Last FM. Basically this worked fine for me as a subscriber for some time but all of a sudden now returns an error when you try to use the radio "An error Occurred. Incorrect response form Server". I can log in fine and it scrobbles fine from music in ATV but wont play radio which is a pain as thats what I want the aTV for...

I can access radio fine from my PC account just not ATV Flash.

Have removed and reinstalled, restarted etc.

 

Please help.

 

Anyone?

Can you check to see if Last.fm is up-to-date in the Maintenance --> Mange Plugins menu?

Will check. But to try and get it working I did un-install and re-install so surely it would be the latest?

Well after 2 weeks of it not working it now works.

I did nothing so who knows.

Thanks Max.

Ok, must have been some weird network issue then. 

Glad to hear it's working for you though.

This has been happening to me for quite some time now (approx. 6 weeks). Are there any solutions to this problem? I am able to log in but as soon as I try to do anything else, I get the dreaded screen “An error occurred. Incorrect respone from server”.

Can you check to ensure the Last.fm item is up-to-date through the Maintenance --> Manage Plugins menu?

James, yes I have updated to the latest version. However, the error still persists.

I have altered my DNS settings according to http://portal.unblock-us.com/ in order to be able to access US functionality (as I am in South Africa). I thought this may have been the problem but I have used the last.fm plugin before on these settings and it has worked perfectly. Any idea if this is causing the instability of the plugin?

That is likely the cause of the problem. Both the Last.fm plugin and Last.fm servers have a number of location checks to prevent streaming outside the designated regions.

Sorry.  :frowning:

How I can update in newest version 

with smart Installer it does go

Plaese help.

KlausD

Hi, i am in Colombia South america, and i have the same problem, i am agree with Max, i made two  test.

Test 1:

I get an american IP with StrongVPN, and last.fm works PERFECT.

Test 2:

I changed my DNS with the configuration of www.unblock-us.com, everything works (internet, youtube, videos from apple TV, etc.) but the last.fm doesn´t work, say “An error Occurred. Incorrect response from server” in spanish “Se ha producido un error. Incorrect response from server” so, the problem is the unblock-us if you compare with strong vpn, with strong you obtain a real USA IP while with unblock just resolve through another DNS  but if you see your IP solve to your real location. 

Sorry its an old thread but I get this. I just upgraded to aTV 1.5 and then installed Last.FM, not used it before. Its the latest version. But I get this error. I am not using any proxy or custom DNS or anything. I am in the UK.