Last.FM "Device not supported in your country"

Hi,

I am last.fm subscriber and I do not have any problems playing the last.fm on my mac via web or the dedicated tool.
However, with atv flash and the last.fm app I get the following error when I try to use it: “This device is not supported in your country”.
I’ve seen posts  about this prlblem on this forum but I didn’t see any workarounds.
Are there any working solutions out there (like vpn)?  

I am currently in Denmark and I have recent Beta5 aTV Flash version.

Thank you in advance.

Unfortunately Last.fm streaming on the AppleTV is not currently available in Denmark.

We’re hoping to have streaming available in additional countries available soon.

 

What about using VPN?
I am confused how one can install and configure it.
I only found threads regarding older atv flash versions where it seems the openvpn was integral part of the atv flash? 

Currently there is no VPN feature available for the 2nd gen AppleTV.  :frowning:

That is why I was so confused.

Currently, I am using last.fm app on ipad and I use airplay on atv to stream only the sound.
This works but there is no video (albums, covers etc) which sucks.
The VPN would not only solve this issue but would enable the netflix access.

I guess I could try to put vpn on outgoing router but sending all traffic isn’t a nice way.
Anyway do you know if you enable the vpn on atv you still would have home-sharing? (I guess not).

Greetings. 

Not 100% sure if using an external VPN would affect Home Sharing, but I don’t think it would.

James, I don’t know how does it work but I just tried the unblock-us.com and damn it works without any VPNs.
I am listening right now last.fm from the atv2 and I have everything.
The funny thing is that you just change only the DNS entries in Network Settings to theirs, so they can just fake original IPs.

That works but it’s expensive!
7 days trial and then $5 a month!

You can use the XBMC client to do this.

Fixed this issue by setting my US account. Used to work several days, but for the last tree days it says: server error -try again later. Day by day. On other devises as well on web - everything works. Tried another last.fm account - same situation - server error. What could it be?