KnowledgeBase documentation needs to be more explicit

I can not install your software, and everytime I’ve tried it takes at least half-a-dozen attempts. This latest version has been the hardest. I’m trying to be lenient in my patience, because I have caught myself making stupid errors, which you’ve clearly documented, but I’ve failed to read. However, usually by the 3 or 4th attempt I’m over patient and even go to the length of restarting my computer before each major step.

Here is my problem, which I will follow up with how this can be resolved by providing more explicit instructions in your KnowledgeBase article. I’m speaking specifically to this article and step: “Jailbreaking 101 - Seas0nPass” in relation to aTV Flash (black) - 2nd gen Apple TV.

First, to clarify I’ve done a restore of my AppleTV via iTunes to get a fresh start. I do this by restarting my computer, opening iTunes, and connecting my AppleTV via USB and using AppleTV restore option in iTunes. All is fine and dandy.

Then I start with you instructions: “Jailbreaking 101 - Seas0nPass”. First, I do another restart before proceeding though, because why not, right? So I restart computer, open Chrome to read through your instructions and begin. I download latest version of Seas0nPass and run. Note: I only have Chrome and Seas0nPass running, and no iTunes at this point. Your instructions should clarify this though. Should a user have iTunes open before jailbreaking? Does it matter? or does it not? Please specify.

I fire up Seas0nPass and click “Creat IPSW” and it immediately prompts me to connect my AppleTV via USB to start. So I do so. Perhaps you should also explicitly state that this will happen to validate whether a user should see or not?

I let Seas0nPass run through its steps and I get to the good old: “Waiting for device to enter DFU mode. Connect USB then press and hold MENU and Play/Pause for 7 seconds.” This contradicts the beginning Seas0nPass prompt for me to connect my device before I can even start jailbreaking. Why would I have to “Connect USB” when it IS ALREADY, because I was prompted to connect it before I could even start the “Create IPSW” process. Your documentation NEEDS to clarify that please. Am I to disconnect, and re-connect at this point? Was it a bug that I was prompted to connect my AppleTV before even starting the jailbreaking process, and when I clicked the “Create IPSW” button? or is it a bug that I see the “Waiting for device to enter DFU mode. Connect USB…” I’m assuming the later is not a bug since it is referenced in your documentation, but can not be too sure, because your documentation isn’t specific enough to reference the other prompts I mention, therefore making me lose faith in the whole process to begin with.

So, here I am at the “Waiting for device to enter DFU mode… Connect USB then press and hold MENU and Play/Pause for 7 seconds.” and this is where I’m completely stuck, and always get stuck in the past. I’ve tried holding Play/Pause for 7 seconds and no go. I try a dozen times, and no go. I try holding for 10 seconds, and no go. I try 12 seconds, and no go. I try standing on my head, and wearing a tinfoil hat, and no go ;)

How do you advise I get past this step please?

I initially upgraded when aTV Flash (black) 2.3 came out. I took notes when I did, and when I upgraded that time I took the same steps I mention above, but during the jailbreaking process (I reference above) I also plugged in the power cable when prompted with the “Waiting for device to enter DFU mode… Connect USB,” even though I’ve seen you explicitly state that one should not do so, but it worked. This also confuses me, because it contradicting what I’ve seen you mention otherwise in the forums. I’d find a ticket to reference, but don’t feel like hunting one down (losing patience).

However, I started to experience horrible processing times on my AppleTV and eventually it got to the point where it was just a flashing light, and bricked. So I thought I would do a complete fresh restore and install.

I’m a developer and know how frustrating it can be to have documentation, and user’s not reading documentation, and then complaining (aka user error). I’m trying to be patient, and would love to know what I’m missing, but do feel a few more lines to your documentation could greatly increase conversion (aka ease of use), and hopefully decrease support tickets.

Here is reference ticket where you state: 

Just FYI, the power cable should not be connected when jailbreaking the AppleTV. Only have it connected when walking through the tethered boot process.”

I’ve followed the instructions mentioned on this ticket:

"1) Connect ATV2 up to a power source (contrary to the instructions)).

2) Open iTunes

3) Hook up the micro USB.

4) Then remove the power cable (standby light should be blinking), wait a second or two and then press 'menu' and 'pause' together for 7 seconds."

and now I'm at the step that says: "Restoring in iTunes. Please wait while script is running..." and I sit, wait, and watch for 10mins., 20mins. and nothing is happening. :(

I’m attaching a copy of my log. I deleted the last 1000+ lines, because they were just the last line error message repeated infinitum.

Here is my most recent attempt:

  1. Delete every file and folder associated with Seas0nPass, including every .ipsw and Seas0nPass application itself. I used to remove application and all/any of its hidden files and folder.

  2. Restart computer, plug in AppleTV via microUSB, and use iTunes to do a restore of AppleTV with upgrade. I don’t believe this necessary, but can’t hurt to start with default AppleTV, right?

  3. Restart computer again. Can’t hurt right?

  4. Download latest version of Seas0nPass, and run.

  5. Click ‘Create IPSW’, and prompts me to connect my AppleTV. I do so via microUSB, and not power cord. Click ‘ok’ to verify that I’ve connected AppleTV and can start Create IPSW process.

  6. I wait, and get to screen that states: “Waiting for device to enter DFU mode…Connect USB…” Once at this step I follow instructions found on other ticket that seems to have worked for other in the past:

  • Connect ATV2 to power source (contrary to instructions)
  • Open iTunes
  • Hook up the microUSB cable
  • Then remove the power cable (standby light should be blinking), wait a second or two and then press 'menu and pause' together for 7 seconds

Seas0nPass does recognize it as in DFU mode and proceeds. It uploads .dfu to device, and then states: “Restoring in iTunes. Please wait while script is running…” iTunes opens and I stare at iTunes while it does nothing for 10mins.+

Very frustrating.

My resolution was to no longer use Firecore’s aTV Flash (black), install PlexConnect, and tempted to ask for my money back. I love how I had this while support discussion with myself. Great support too (strong sarcasm).

I know this is an old thread, but I agree:  what actually happens contradicts the documentation on several points.  It is indeed frustrating!  Thank you for sharing your progress, even though no support was received.