Just installed aTV, nothing but problems with the plugins

So I’ve just successfully installed aTV without problems, but I’m having a lot of issues with the plugins. Since I couldn’t find any information about the issues I’m experiencing, I’ll post them here so maybe someone can help me out.

1. Media/Sapphire

  • I can import, I can choose IMDB titles for my movies (VOB files in folders), I can choose cover art. Import says it’s successful. But when I leave the Media section in Apple TV and return, everything I just imported and worked on is gone. It’s like it doesn’t remember anything. I’m importing from an external usb drive FYI.

2. nitoTV

  • Can’t open “Files” (just makes a sound and doesn’t go further) , trying to open “Network” gives me an error and tells me to reboot Apple TV. So I can’t use nitoTV at all.

3. Files / ATVFiles (beta)

  • I can access my usb drives, trying to open a VOB file it shows an error telling me to reboot the Apple tv.

4. XBMC/Boxee

XBMC works somewhat ok, I can view DVD from usb drive, but can’t switch between subtitles or language with the Apple remote unfortunately.
Boxee looks nice, but it takes ages to import my movies, and the worst thing is that it forgets the movies once logged out, so there is no point importing. Also trying to play VOB files it starts somewhere in the middle of the movie or shows the wrong subtitles and/or language. So Boxee, although it looks nice, is completely worthless to me.

So overall it’s been a disappointing experience for me, especially since I couldn’t solve any of these issues myself via a Google or aTV search. So my last hope is this forum and so hopefully I can get some help here. Thank you.

You may try the following steps to help resolve your issue.

  1. Ensure all updates have been installed through the Maintenance --> Manage Plugins menu.
  2. Run Smart Installer as described here: http://wiki.atvflash.com/index.php?title=Smart_Installer

Thank you for your answer, however I should have mentioned that I already did all the updates and the smart installer too. But the smart installer did show some issues…

I’m not sure why I have these problems, it’s a normal up-to-date Apple TV and up-to-date aTV flash software. Hopefully, these problems can be solved in another way.

Please let me know if you need any information in order to find the source of the problem.

The nitoTV --> Files menu won’t open if there are no files currently present on the AppleTV. There is a guide below for adding files.
http://wiki.atvflash.com/index.php?title=Playing_Video

If you having issues with the nitoTV --> Network menu you may try the steps shown here: http://forum.atvflash.com/viewtopic.php?f=6&t=3323&p=13977#p13977

OK, thanks.

Here’s what the smart installer shows (problems only):

kextload: cannot resolve dependencies for kernel extension /System/Library//Extensions/IODVDStorageFamily.kext
kextload: kext doesn’t have all dependencies
kextload: can’t generate internal dependency graph for /System/Library/Extensions/IODVDStorageFamily.kext

2010-07-25 17:28:40.476 nitoHelper[195] Bluetooth.prefPane install failure

2010-07-25 17:28:41.508 nitoHelper[195] Bluetooth.menu install failure

kextload: loaded version 1.4.7 of module com.apple.filesystems.msdosfs differs from requested version com.apple.filesystems.msdosfs
kextload: loaded version 1.0.12 of module com.apple.driver.AppleSMBIOS differs from requested version com.apple.driver.AppleSMBIOS
kextload: loaded version 114.2 of module com.apple.AppleDiskImageController differs from requested version com.apple.AppleDiskImageController
unlink: /Users/frontrow/Movies/Mac OS X 10.4.9 Combined Update (Intel): No such file or directory
2010-07-25 17:28:46.324 nitoHelper[195] Installation completed successfully

After running the smart installer, I followed your advice and removed ‘mounts.plist’ from the Library/Application Support/nito folder. After this, the reboot error stopped showing after clicking on ‘Network’ under the nitoTV menu. But trying to connect through AFP to my Airport Extreme shows this error message:

AFP is not activated or is missing essential parts, Smart installer with a 1.0 recovery dma in /Documents will fix this issue

Looking in nitoTV’s - Settings > Extra > Services > AFP access it shows that this function is “off”. Trying to enable it shows this error message:

AppleFileServer Missing, cannot enable

How can I resolve this issue please?

About nitoTV Files: I should be able to find external USB drives there too right? There are two USB drives connected, but I still can’t access the nitoTV files section.

BTW am I the only one having these issues with Apple tv hacking? Surely these problems must have come up before? Or does it have something to do with newer model Apple TV’s?

Ok, the Smart Installer output looks ok.

By default the AppleTV will attempt to connect via the AFP protocol, however most newer AppleTV units will not support this protocol. The SMB protocol can be used in its place by setting up a ‘Manual Share Point’. We have a guide for setting this up at the link below.

http://wiki.atvflash.com/index.php?title=Network_Streaming

This does not work. Any other suggestions.

 This is ridiculous. Why don't you tell people with newer models that AFP wont' work?

 

The link you posted to support, DOES NOT show how to setup an SMB share, it only shows how to create a manual AFP share, there's NOTHING anywhere that shows how to create SMB share, or what to put in for the address. Do I have to prefix it with SMB? I just bought this yesterday, and I'm 100% regretting it. AFP can't be installed, FTP can't be installed, SSH when clicked, doesn't do anything, no error nothing… How exactly am I supposed to share non apple files with the device?

 

Yes I've run the smart installer, I've repaired the apple tv, smart installer gives back a few errors. Everything is up-to-date. I have a file in nitro from a managed to move with a USB key.

 

I want to mount my appleTV on my computer, your software claims I can do this, but apparently it can't, and if it can you have NO tutorial that is for SMB. Do I need to type smb:// before the address? what do I type EXACTLY to get it to mount my mac?

Sorry, the link above is outdated.

The current guide for connecting via SMB can be seen here: firecore.zendesk.com/entries/259299-streaming-files-over-the-network

That guide includes a demo video that outlines how to setup SMB specifically.

I'm having the exact same problems.

Will try to revert Apple TV Software to an earlier version (2.4 for starters).

How come nobody is responding to this post?