Just bought an ATV with 4.3 (2575) installed. Need Help

Just bought an ATV with 4.3 (2557) installed. I know 4.4.x is the latest firmware and Apple has stopped signing blobs for previous firmwares. I noticed seas0npass requires you to restore the firmware unlike greenpois0n. Since I don’t have the SHSH blob to 4.3, will I get an error using seas0npass? Will I end up having to install the latest firmware and use tethered jailbreak since I have no previous SHSH blobs saved? thx


I ran into the same problem and here is what I did to get the SHSH blobs for the device. I put the device into DFU mode (I achieved this easily by holding Menu & Play/Pause then plugging the USB cable in counting 7 seconds [at that point I heard the device connected ding from my PC] after that I released the buttons and was in DFU). I then used an app called USBVIEWER and found my ECID (Google this if you need help with it). After I had my ECID I used TinyUmbrella and under options unchecked request shsh from cydia and then under general clicked Manual ECID. I entered the ECID and Name of the device (Usually Apple TV) and clicked Create Custom Device. Once I did that I was able to save the SHSH Blobs for 4.3.0 and 4.4.2.

I’m in the same position.  I have a newly purchased ATV2 with 4.3 out of the box.  Does the method described by mattygdot work?

I was able to save my SHSH Blobs this way and was able to reflash stock 4.3 firmware so saving them that way did work. Not sure how long before Apple stops signing 4.3 though so try it now while you can.

I followed your instructions and saved my shsh files via TinyUmbrella using the manual ECID process.  It says that it was able to save my 4.3 shsh files. 

I created a custom firmware using Seasonspass, then ran the TU TSS server and tried to restore using iTunes, but I’m getting 1600 errors.  Is this the same process you used?

Is your hosts file set to redirect requests for the SHSH Blobs to the Cydia server? I used the same processes and my device allows me to attempt to restore it using the cached SHSH Blobs however I get an error when attempting to restore the custom IPSW, stock 4.3 works fine.

As noted in this thread: http://forum.firecore.com/topic/6163