Jellyfin Smart Groups 1080p getting misreported

I am running a Jellyfin server on the backend. I have been using Infuse with it. I have the merge versions enabled on the server and I discovered Smart Groups in Infuse. I have 1080p content and below in one movie library and 4k content in another. Smart Groups displays the matching content from both libraries together which is excellent. I have Infuse set to play the highest quality copy. When I am on the movies view it says it has two items. When I select the movie, I see two files and both of them are labeled 4k. If I look at the bottom, I can see the file name when one version is selected. This is the only way I can tell if I am looking at the 4k or 1080p file. I assume this is a bug and that the 1080p file should be tagged as 1080p.

You may want to run both through mediainfo and verify that the file title is correct with the resolution. I’ve seen a couple where they were mislabeled with incorrect resolutions.

You can also use VLCs media info window while playing to check.

When using a media server like Emby, Jellyfin, or Plex Infuse will rely on the specs provided by the media server instead of scanning the actual file.

Were the video files recently changed or replaced?

Can you check and see how these specs appear in the Jellyfin web UI?

Does using the Refresh option in Infuse on the problematic file have any effect on which resolution is shown?

The 1080p versions were available first in most cases and 4k versions have been recently added. I checked a few movies over the weekend and found both files reporting as 4k/4k HDR. I looked at one of the files with MediaInfo as requested above and the file is definitely 1080p. I checked just a minute ago on a few new files and they report the resolutions correctly. 4k/1080p. Hitting the refresh for those files did not seem to make a difference.

By the way, the files that Infuse incorrectly as 4k report correctly in Jellyfin.

Update: a couple of movies were added to the server overnight. First the 1080p copy was added and then a 4k copy. For one movie added last night I see two copies and they are both labeled as 4k HDR. When I scroll to the bottom and check file names I can tell which one is 1080p vs. the 4k one. Another moves was added today and in that case, one file is labeled as 4k HDR and the other is labeled as 1080p. It’s a strange inconsistency.

Can you post the specs for both of these videos, as shown in the Jellyfin web UI?

You can view this for each video by selecting the ‘Media Info’ option that appears in the video’s menu.

Video

Title4K HEVC HDR
CodecHEVC
ProfileMain 10
Level150
Resolution3840x2160
Aspect ratio16:9
InterlacedNo
Framerate23.976025
Bitrate16792 kbps
Bit depth10 bit
Video rangeHDR
Video range typeHDR10
Color spacebt2020nc
Color transfersmpte2084
Color primariesbt2020
Pixel formatyuv420p10le
Ref frames1
Audio

TitleEnglish - Dolby Digital+ - 5.1 - Default
Languageeng
CodecEAC3
Layout5.1
Channels6 ch
Bitrate256 kbps
Sample rate48000 Hz
DefaultYes
ForcedNo
ExternalNo

Video
Title: 1080p H264 SDR
Codec: H264
AVC: Yes
Profile: High
Level: 40
Resolution: 1920x1080
Aspect ratio: 16:9
Interlaced: No
Framerate: 23.976025
Bitrate: 6845 kbps
Bit depth: 8 bit
Video range: SDR
Video range type: SDR
Pixel format: yuv420p
Ref frames: 1
NAL: 4

Audio
Title: English - Dolby Digital+ - Stereo - Default
Language: eng
Codec: EAC3
Layout: stereo
Channels: 2 ch
Bitrate: 128 kbps
Sample rate: 48000 Hz
Default: Yes
Forced: No
External: No

@James have you come to any conclusions yet on the 4k reporting?

I can’t seem to replicate this on Jellyfin 10.8.10 and Infuse 7.6. Specs for both 4K and 1080p files are shown correctly along with the correct tags.

Are these the versions you are running or are you using something else?


I checked my versions and they match yours. I installed Infuse on my Mac this morning and the library info synced from iCloud. See the attached screen shots from the the Mac and also from my phone. The Mac and Apple TV are reporting the same data but the iPhone thinks there are three copies (two 4ks) and one (1080p). I my non 4k and 4k copies are in different library folders. I checked both and there are only two copies: 4k and non-4k. Should I remove the library and add it again? Maybe something is corrupt or there is a detection issue?

Don’t let me derail this but do you by any chance have a copy or copies downloaded to the iphone so it may be seeing local files for it in addition to the streaming library?

Yes, I think I have the extra copy resolved from the phone. I moved to Jellyfin from Plex and the phone still had a plex library connected. I removed that and now I see two copies as shown. Now it shows both “4k” copies like the other devices. Very strange.

FYI-

I removed the library and turned off iCloud added the library again to the Apple TV. It synced again and I see the same issue with that movie, both copies show as 4k.

@James I’m just circling back to see if you have any other ideas. I can see where some movies show two 4k versions (even though one is 1080p) and other show a 4k copy and a 1080 copy. I tried removing the share and adding it again to no avail. Appreciate any addition debugging or advice. Thanks.

I came across this thread which talks about tagging issues. Infuse showing 1080p tag for 4K files - #15 by james

I don’t see a way to edit the metadata in infuse. Is this because my files are coming from Jellyfin?

I fixed the issue. I think the root cause was that when I first setup Infuse with Jellyfin, I only added my 4k library so I could test Atmos playback. From I added the additional libaries. I think the files from, the HD library were getting pulled in but the tags for the 4k content was syncing from iCloud. I purged the library from my Mac and turned off iCloud sync. I added the libraries and confirmed that the grouped versions of movies were correctly showing a 1080p copy and a 4k copy. From there, I went to my other devices, turned off iCloud sync and removed the Jellyfin share. Next, I used my phone to purge the Infuse data from iCloud. From there I added the Jellyfin server to an Apple TV and let it sync and turned on iCloud sync and everything looks good. I have 4k and 1080p copies in Infuse now. I will add the other items to the mix but it looks like the info was cached in iCloud and coming back to haunt me.

Hmm, that is a little strange.

Infuse won’t actually be syncing details for media server files (aside from the connection details) through iCloud, but maybe just starting fresh was enough to get things cleared up.

Do let us know if the issue appears again.

@James you might want to double check what is synced/stored in iCloud or cached in the app when the iCloud sync is on. I removed the share/server from the Apple TV a couple of times previously and also had tried that on the Mac. It seems that data regarding library files was getting cached somewhere. I manually refreshed 200 movies or so which was a pain and took a while. Then I got tired of doing that and removed the libraries and added them again and it undid all the work I had done manually which was frustrating. That’s when I decided to disable iCloud sync, purge iCloud, remove the share and add it again syncing the libraries and this worked. So glad I did not need to manually refresh over 800 movies.