Jeez - What a mess!!!!

I’m trying out Infuse across iOS and Apple TV before buying. On the basis of what I’ve seen at the moment it’s not going to happen!

  1. How do you re-add a single movie to a movies folder? I tested the download function and mistakenly hit delete (the bin under More) and it trashed the film from the library view, not the local version. How do I get it back without deleting the app and starting over.

  2. Once it was deleted I got stuck with an empty folder at the top of the screen for the movie with seemingly no way to get rid of that. So if I DO want to delete 10 movies from its Movie view I’m gonna be stuck with 10 empty folders before I even get to what I DO want to see.

  3. Metadata. Complete disaster. It’s started sucking in all manner of junk that has NOTHING WHATSOEVER to do with the tracks they’ve been applied to. First two episodes, season 1 of the series ‘24’ are now have Metadata for a James Bond movie and and some other random nobody ever heard of movie. Is all the metadata fetching such a complete disaster?

Might be a few features of this that are quite nice but at the moment it just seems WAAAY too much like a high-maintenance app that NO WAY will I pay for.

For issues 1 it sounds like you have deleted the movie file from your server rather than from your iOS device … Not sure if you intended to do that. If it was not intended then you will need to restore the film on your server.

If you don’t want to allow deleting video files from your server I would suggest that you turn off ‘File Management’ in the settings menu. The ability to delete video files from the server is a relatively new feature, due to user requests, to support users who do not wish to keep a video file once it has been watched.

Can’t help you with issue 2 as I don’t store films in individual folders, or delete films on my server from Infuse.

Issue 3 suggests to me that the names of your episodes of 24 do not conform to the form expected by Infuse for TV series and therefore thinks it is a film rather than a TV series, thus resulting in incorrect metadata. Infuse is generally quite good at getting Metadata for TV series provided the episode names conform to the form it expects … As describes on firecore’s web site in the support section.

Thanks for the help. Hmmm. You were right on the deletion front. Dangerous or what?? Using the File Management for deletion actually deleted the movie altogether from Apple TV, which took it out of iTunes but did so without a trace!!! Wasn’t in the trash or anything, as it would be if you deleted from within iTunes. Luckily I had a back up I could restore from. Handling deletion in this way to me is really poor and I’ll have to see if I can stop Infuse having this kind ‘nuke the file and any trace of it’ access to my server / iTunes. For now, File Management will be staying off. The empty folder seemed to be the folder that the movie WAS in in iTunes but then just became an empty folder bearing the name of the movie once Infuse had managed to do its stealth deletion on my server. Not impressed, not impressed at all!!!

It looks like your’e right on the metadata front too. That said ALL my stuff has had the correct metadata applied with iVI before being imported to iTunes. Plex also seems to handle the metadata handling for all my series too, and certainly without the disasters that Infuse introduces. Given the way it nukes files on deletion I’m not sure whether the Fetch Metadata also edits / corrupts source files on the server or not. Until I am sure, Fetch metadata will also be turned off. I’m certainly not going to go through hundreds of episodes of TV series renaming them to accommodate Infuse quirks when iTunes and Plex are capable of displaying EVERY show correctly as they stand now. It starts to look like there’s no actual positives to even bothering with this app at all.

The Library is a mess too. I’ve added the folders for movies and TV series shares to the Library but I have TV shows in Movies, nothing in TV shows and Other seems to be stuffed full TV series all over the place. Maybe again a naming thing, a naming thing that both iTunes and Plex seem to be able manage without ANY difficulty and to display the media information for EVERYTHING correctly. No way am I going to undertake a major renaming exercise merely to accommodate Infuse.

Checking on the screwed up ‘Other’ aspect of Library it seems that you NEED to have Fetch Metadata enabled for it to work. So I double checked on the series causing the main problems - 24. I double checked the naming conventions for this series on the TVDB and my files are names EXACTLY as required by the TVDB for both iTunes and Plex to work. According to the TVDB each episode SHOULD be named like this: 01 12_00 A.M.-1_00 A.M. (HD). According to the guides here I’d have to go an rename every one to “24.s01e01” etc, and I’m still not sure that would work and may well screw up everything for apps that CAN work with the TVDB naming conventions. So, I spend hours changing things to MAYBE get it to work for Infuse then screw everything up for Plex and iTunes that DO work. Nah - I’ll pass!!!

Just lucky I could try out the free version before buying, looks like one of those ultra-high maintenance apps that for some reason chooses to do things different to Plex and iTunes for which my media is named fine. If I find a way to trial it without god knows how many hours of work I’ll give it a spin. Otherwise it’ll get deleted, after I review it on iTunes!!

Not impressed with what I’ve seen so far, especially the Library Management which seems abysmal. The lack of a search function on the sub forums is also about as much use as a chocolate fireguard, took me to read through the threads to find there was even a search function at all!

Glad you managed to recover the deleted file. With File Management turned off it won’t happen again.

I can confirm that Infuse does NOT write any metadata information back to the server. It is a feature requested by some users, but which is certainly not available in the current version or a feature that I have seen announced as being actively worked on.

As my video collection has grown whilst using Infuse on iOS and tvOS (and previously Infuse (black) on AtV2) my files are named as required so it all works well for me. However I can understand your reluctance to do a mass renaming for stuff that works for you in other apps.

At the moment it seems there is something SERIOUSLY wrong with the way this app handles metadata. At least in some cases. In the above example the series 24. All the episodes in Season One SHOULD, and in my case ARE, named in accordance with the TVDB naming convention:

01 12_00 A.M.-1_00 A.M. (HD).m4v

This picks up the CORRECT metadata in other apps because metadata retrieval in other apps works as it should. They don’t make a complete pig’s ear of everything in the way Infuse does. Complete and utter disaster in Infuse. Every title in season one is assigned some garbled metadata from god knows where with everything from movie titles to whatever.

Subsequent to S1 all episodes should be labelled like this:

01 Day 2_ 12_00 A.M.-1_00 A.M. (HD).m4v

Merely as an exercise I tried naming season one like this

01 Day 1_ 12_00 A.M.-1_00 A.M. (HD).m4v

and like this

24.s01e01.m4v

Result, nothing. Still a complete mess. So since even renaming the files gives no guarantee it still won’t screw up it’s a futile exercise. Given the importance of metadata handling to apps like this I couldn’t even consider an app like Infuse as a serious contender, or even worth bothering with at all, until the dog’s breakfast that is metadata handling is sorted out. Requires, way, way, way to much maintenance and even then it’s crap.

Of course, the workaround for this it to switch Fetch Metadata off but the problem then is you can’t use the Library feature but I certainly don’t want to let Infuse loose on my metadata in it’s current state. I could never get the Library to refresh and show TV Shows in the right place, instead of under Other, so I’ve turned Library off too.

So, doesn’t work well with metadata, features won’t work in some cases unless Fetch is turned off, if that’s turned off you may as well disable library, leaving you to hunt across drives for media. Great app eh? Back to Plex, at least for now!

Infuse - Deleted.

/video/tv/24/season 1/24.-.s01e01.avi

So the above doesn’t work for you? I just now renamed a random video file and it worked fine for me. Try it for yourself. Regarding the other stuff you mentioned, it’s worth noting that for some movies and shows you may need to include the year, eg Total Recall. I’ve always been able to solve incorrect metadata by renaming the file (usually it’s because I made a typo or missed out the year). Follow the conventions outlined in support documentation metadata101 and I’ll be surprised if it doesn’t work.

If you are fearful of infuse users accidentally deleting files from the remote destination (smb/cifs or WebDAV file server?) you could just create a new user account on the server without write privileges solely for infuse. That will completely eliminate the possibility of this reoccurring. DLNA and iTunes sharing I have no idea about

You’re probably not using it correctly.