JB of ATV2 not possible

Hi,

 

I’ve propably tried 99% of all solutions for issue’s when trying to JB a ATV2.

I have isolated the issue to be the usb connection between itunes, the pc, the cable and the ATV2.

Yes, it enters DFU mode, and ATV2 is visible in itunes and the restore button is present. When initiating the restore, 

itunes always ends with error 1600, just after it is “preparing the apple tv”. On Win7, the “usb removed” sound

emerges two times. After the first time it continues to “prepare”, and after the second time, the error message (1600)

is displayed. This happens with the stock apple, as well as a custom ISPW.

 

I have tried on an iMac, a Macbook Pro as well as Win7 laptop, using different USB ports, an a usb from a dockingstation. Used a bunch of

JB tools such as Greenpois0n, Seas0nPass, iFaith, iREB, sn0wbreeze, PwnageTool. Without power cable connected, with power cable

connected, as well as pulling the power cable at specific times during the itunes restore process. No success -> 1600 error message

 

When connected to the TV, the screen receives no input. Initial the led is blinking once every second, after a while, 3 times a second.

 

Any suggestions besides buying a (few) new Micro USB cables?